2

I have a MacBook Pro with a Windows 10 partition running on Boot-Camp and I would like to convert the Windows 10 partition into a virtual disk/machine that I can use as a VM within a Windows hosted machine using Hyper-V.

While I have successfully created a virtual image of the Windows 10 partition using Hyper-V (and indeed disk2vhd) the problem that I subsequently have is that I am unable to load the a virtual machine using that virtual disk.

I have created a VHD and a VHDX disk image but I'm unable to boot-up a virtual machine that I create with Hyper-V using either disk on a Windows 10 host (I've tried both a native Windows 10 host and a Boot-Camp Windows host).

When I attempt to start up the VM using Hyper-V I get the following error. The "Virtual Machine Boot Summary" states: 1. SCSI Disk (0.0) - "No x64-based UEFI boot loader was found."

Also, I briefly tried to use VMWare converter but clicking on the "Convert machine" button displays a failure so I parked that idea as my preference is for a Hyper-V solution.

My goal is to be able to run my Windows 10 partition as a virtual machine on Windows 10 (whether a native or boot-camp version of Windows 10) and any help is greatly appreciated!

Many thanks in advance!

4
  • Did you use Generation 2 or Generation 1 while setting up your new Virtual Computer in Hyper-V? Does it work if you try it with Generation 1?
    – SimonS
    May 24, 2016 at 17:28
  • Hey SimonS, I definitely tried it with Generation 2 and I'm fairly sure that I also tried the creation with a Generation 1 subsequently but no success with either approach. Thanks!
    – MartyG
    May 25, 2016 at 0:37
  • fairly sure or definetly sure ;-)? the error seems to occur because of Generation 2 which enables the SCSI start option. if not, can you give some more error information? it's not enough to be definetly sure what causes the problem
    – SimonS
    May 25, 2016 at 8:15
  • SimonS - Thanks again for your feedback! So I went back & created a Generation 1 VM from scratch & cloned my hard-drive as before which has the BootCamp partition. On start-up of the VM I got the following error (I can't recall if this is what I got before) - "Boot failure. Reboot and Select proper Boot device or Insert Boot Media in selected Boot device." Thanks to you mentioning about the 'SCSI start option' which prompted me to check the VM BIOS settings which I realised that there was no SCSI boot option. So I remove the VHD from the SCSI adapter & connected to the IDE & Voilà! :-)
    – MartyG
    May 25, 2016 at 20:39

1 Answer 1

3

There were a couple of factors to the problems that were preventing the VM loading but thanks to SimonS for helping point me in the right direction to a suitable work-around.

Firstly, creating the VM as a Generation 2 proved problematic because the hard-drive could only be attached to a SCSI adapter but this was unable to boot hence why I was getting the error "No x64-based UEFI boot loader was found". I'm not quite sure why this doesn't work but the solution here was to create the VM as a Generation 1 VM.

Secondly, while I had also briefly attempted to create a Generation 1 VM previously I was also unable to load the VM. More recently the error noted when I tried to load the Generation 1 VM was "Boot failure. Reboot and Select proper Boot device or Insert Boot Media in selected Boot device".

Solution

The solution was to create a Generation 1 VM and attach the Virtual Hard-Drive (either VHD or VHDX) to the IDE adapter and NOT the SCSI adapter and this allowed the VM to load with the virtualised BootCamp VM.

3
  • I'm hoping you can remember as this 4 years ago for you. Was there a trick to getting Disk2vhd to complete? I'm using Disk2vhd v2.01 which has the toption to "Use Vhdx" (Gen2) and "Use Volume Shadow Copy". In my use-case, I didn't create a large enough partition on my MBP and I want to enlarge the partition which unfortunately means a complete reload. I'd like the VHD so I can copy over anything I might have missed (from a configuration standpoint). I'm confident in my backup but...
    – HPWD
    Apr 23, 2020 at 21:14
  • @HPWD, Sorry, but I haven't been using these VMs for quite a while now so none of it is fresh in my head, so unfortunately I don't have any suggestions. Good luck and hopefully you find a solution.
    – MartyG
    May 27, 2020 at 12:20
  • 1
    Just for grins, I ran Disk2VHD again and it estimated 20min. It did not complete but the green bar was soooooo close to the end that after 30 minutes, I clicked cancel. I then moved the VHD to another computer running Hyper-V and to my surprise, I was able to mount the VHD. I didn't expect that (didn't think the VHD had been completely written). HyperV is also able to run the VM. What a good day!
    – HPWD
    May 27, 2020 at 21:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .