1

I am trying to install Beef in a WIndows 10 - 64 bit PC. I followed the instructions provided in the following link:

https://github.com/beefproject/beef/blob/master/INSTALL.txt

But I keep getting this error:

An error occurred while installing therubyracer (0.11.4), and Bundler cannot continue. Make sure that gem install therubyracer -v '0.11.4' succeeds before bundling.

I drilled down a bit & found that the installed version of therubyracer is 0.11.0beta1 x86-mingw32 whereas the installer is searching for version 0.11.4

In the link provided above, the following lines are mentioned in line 38:

Finally, edit beef's gem lock file by replacing the required ruby racer version with the version downloaded from the link above.

But when I do that I get this error:

Your lockfile is unreadable. Run rm Gemfile.lock and then bundle install to generate a new lockfile.

Can anyone please help me out with this?

migrated from security.stackexchange.com May 21 '16 at 20:17

This question came from our site for information security professionals.

  • What are the rights on the Gemfile.lock? – Dale May 21 '16 at 21:23
  • The current user has full access with full control enabled. – Neel May 22 '16 at 15:48
-1

Make sure that all versions coincide E.G. If you are using a 64-bit version of Ruby make sure you use the appropriate 0.11.0beta1 x64-mingw and not the 0.11.0beta1 x86-mingw32 as you mentioned above.

Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.