I have a laptop with Thunderbolt(Mini Display Port) and ofcourse TV has HDMI port. Si I bought a Thunderbolt to HDMI cable and connected the devices but TV is just not showing up when I press Detect.

Now, this laptop is not having any issues when I connect it with my external monitor, its just the TV which is not being detected.

All I see is No Signal when I turn on the TV and choose the port from laptop

Any suggestions?

  • 1
    What is the exact model of your laptop?
    – TheKB
    May 22, 2016 at 7:55
  • 1
    Can you provide a link to the Thunderbolt/HDMI cable? Describe the connection for each hardware combination listed.
    – fixer1234
    May 23, 2016 at 5:48
  • 1
    Have you got the latest drivers.... I think Intel have a newer version than Lenovo...
    – Kinnectus
    May 23, 2016 at 6:58
  • 1
    You could try a better-quality cable.
    – harrymc
    May 25, 2016 at 8:22
  • 1
    @harrymc: Tried that and my installation failed. however, I also tried connecting a macbook to my tv and it is also having the same issue. now, I am thinking that it may be some setting on the TV rather than my PC which is causing the issue?
    – Lost
    May 27, 2016 at 5:27

5 Answers 5


On your laptop while it is connected to the TV, see if the TV is being detected as a secondary display. You can do this by going to the Intel HD Graphics control panel. Open it by right clicking on the Intel HD Graphics icon in your notification drawer (you may have to expand it) and choose Graphics Properties. In the control panel, choose Display, then Multiple Displays from the sidebar. See if your TV is detected here. If it is detected, you will see a page with options to clone displays or extend desktop. If your TV is detected, then the single display option will most probably be selected, with your laptop display being the one. You can choose the TV in single display mode or choose to clone displays. This should work if your TV is detected.

If it is not detected at all by your laptop there may be a few causes. I will try to cover the ones that I can think of:

The cable may not be the right one for you. If you can, try it out with other device combinations (a friend's TV and/or laptop etc.) to see if it works. Try a different cable if you have/can borrow one.

Try the other HDMI ports on your TV.

Based on some suggestions in iFixit forum, you could try this. Apparently the power off delay works. Disconnect all HDMI sources from the inputs. > Unplug the power from TV/LCD for 10 minutes. > Plug the TV/LCD back in. > Connect the cable to your laptop. > Repeat previous step for each HDMI port.

Resetting the TV may fix it if it is a setting problem. (From the same forum). There is also apparently another way to reset it by holding the Exit button for around 30 seconds. I cannot test it out as I don't have a samsung TV:

Power off the TV and then on your remote control press Mute 182 Power simultaneously (or sequentially. Some users differ on this. Try the other if one doesn't work). The TV will turn on with a secret menu and all you will have to do is press enter a few times and the TV will do a deep Factory Mode Reset just like the TV came out of the box new! There is also a way to reset the HDMI ports in that menu as well.


OK. I found the solution to the problem. The problem was that Mini Display Port(Thunderbolt) HAS TO HAVE a active adapter connected to be able to successfully convert signals from DP to HDMI.

As soon I replaced a regular converter with an Active Converter which I bought from Amazon:


It just started working.


This sounds so familiar. Troubleshooting is tricky. I too remember getting no signal from my Samsung for my PC.

Before you buy a new cable:

  • Check your refresh rate - 60mhz or 120mhz. Control panel, display, advanced settings, monitor. You may have to lower your refresh rate for your "slow" TV to handle it. A monitor is powerful and why they are expensive. TV's are horrible monitors, but you can get it to work. And also check your color; true color? Maybe try a lower bit rate for testing.

  • Also check your resolution on your PC. Control panel, display. You might have to scale down (meaning your icons will be larger) your resolution for testing to match what your TV can handle. In my experience the TV always puts the icons overly large, but that's TV for you.

If tinkering with settings doesn't work out, try a new cable. In my experience with HDMI a ton of them are defective. I bought 5 before knowing this and only two actually worked.


You can try to turn the Anti-Virus off on the laptop before connecting it to the TV. I have had an issue before where the laptop just would not connect. To do this just set the Anti-Virus protection to "off till restart".


Try changing the source on your TV and see which HDMI connection is active. Most of these screens have HDMI 1, HDMI 2, etc. Also check what the resolution on the TV is set to.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.