1

When attempting to install MS Office 2010 on a Windows 7 Professional machine, using administrator account, and I get the following error:

"Error message when you try to install Office 2010: "Error 1920. Service 'Office Software Protection Platform' (osppsvc) failed to start."

I have tried the MS recommendation (both auto and manual fixes) and they do not seem to help

https://support.microsoft.com/en-us/kb/2401987

I also tried running setup.exe as Administator.

I also tried this:

Open Run (Press Windows key + R) > type services.msc and click on OK On the services MMC window right-click on Office Software Protection Platform and select Properties Select the LOG ON tab > change the ‘Log on as’ information from ‘This Account’ (Network Service) to ‘Local System Account’ Click on Apply and OK

I also tried this, but It cant find Network Service

From Administrative Tools > Computer Management, expand System Tools > Local Users and Groups > Groups. Double-click the Users group and click Add. Click Locations and select your computer node. Now: Type Network Service into the 'Enter the object names' OR Click Advanced, then Find Now and select it from the Search Results.

When I tried to add it, it says it already exists - but yet I dont see it At my wits end trying to get this installed

  • Try this icacls "C:\Program Files\Common Files\Microsoft Shared\OfficeSoftwareProtectionPlatform" /grant "Network Service:F" /t after opening command prompt as an administrator – pun May 22 '16 at 14:36
  • I did, it did not change anything – Shane Holmes May 22 '16 at 20:56
  • Try verbose logging off the officer install: blogs.technet.microsoft.com/odsupport/2010/12/30/… - it is not an answer but will get you closer to why the install is failing. Likely a permissions issue of some sort. Process monitor is helpful but verbose logging will narrow down your issue faster. – Sun May 23 '16 at 0:52
3

Having been through this myself, the steps are generally:

  1. Set the service to log on as a different account that should have permissions, e.g. Local System Account as a test.

If the above succeeds, permissions are probably wrong in various locations:

  • Registry key HKLM\SOFTWARE\Microsoft\OfficeSoftwareProtectionPlatform
  • Folder %ProgramFiles%\Common Files\Microsoft Shared\OfficeSoftwareProtectionPlatform
  • Folder %AllUsersProfile%\Microsoft\OfficeSoftwareProtectionPlatform.

Troubleshooting steps generally say to give the account in question (NETWORK SERVICE) "Full" permissions at these locations. I don't know if this is overkill.

Then of course change the service back to logging on with NETWORK SERVICE as it was originally (clear the password field).

  1. If step #1 didn't work... well in my case it was anti-malware software interfering! After closing Malwarebytes software it worked immediately.
1

Try running as a different user for that service temporarily to see if it is write permission issue:

  • Open Run (Press Windows key + R)
  • type services.msc
  • click on OK
  • On services double-click on Office Software Protection Platform
  • Go To Log On tab
  • Change 'Log on as' from '(Network Service)' to 'Local System Account'
  • Click on Apply and OK

If this solves your issue, you'll have to apply the icalcs permission via command prompt (run as Administrator) and make sure it is applied to the correct Windows folder. Your folder location will vary depending on whether you are running Windows 7 32-bit (Program Files) or Windows 7 64-bit (Program Files (x86)).

  • There is no Office Software Protection Platform in my services. – Shane Holmes May 22 '16 at 20:55
-2

Install the program and when the error appears, click on the “Retry” and wait for the error to appear again. Do not click on”Retry” again. Instead, search for the word OSPPSVC at the root of the installation, and change its name; for example, OSPPSVC1, then click on the “Retry” to continue the installation.

  • 1
    Do you have a reference for this answer? – DavidPostill Jul 6 '19 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.