I'm trying to install Matlab, but the culprit is probably Visual C++ Redistributable (which Matlab is installing along the way).

When I run the setup, every time it fails with:

Error 997.Overlapped I/O operation is in progress

I already searched for a solution, and every article suggests to uninstall security updates which I don't have! Many articles are from a couple years ago, while I recently downloaded the Windows ISO and installed it. Could it be that those updates are already installed in my system, but I cannot uninstall them?

What to do?


Similar problem installing E-Prime 2.0 on Windows 10 Enterprise...Same culprit, it seems; same error code. Since I'm not super enough to unpack or compile EXEs (yeah, probably easier than I think), I needed a different solution, and this one worked for me:

In short: Rename the folder C:\ProgramData\Microsoft\Crypto\RSA\S-1-5-18 to C:\ProgramData\Microsoft\Crypto\RSA\S-1-5-18_old

During successful installation of KB3045318 this folder is created again, automatically.

At the end, I copied the missing files from the original folder to the new folder.

Truth be told, I saw another odd error ("support\vc2008 sp1 vcredist_x86.exe copy failed: lasterror=5") during installation of E-Prime, but I was able to dismiss it and complete installation successfully. I also haven't "copied the missing files from the original folder..." because I don't know what purpose they serve, but maybe I should? No explosions so far anyway. What counts is that I now have Microsoft Visual C++ 2008 Redistributable 9.0.30729.6161 (both x64 and x86 versions) installed, and I couldn't seem to do it any other way. This solution was very simple to implement.


Ok, I managed to install Matlab R2016a. I'm posting what I did in case anyone in the future needs this.

The culprit is Visual C++ Redistributable 2008, which Matlab wants to install at all costs (even though I wasn't even going to use it). I downloaded from the Microsoft website all Visual C++ versions, and all except the last one (2015 version) refused to install (same error).

I unpacked Matlab's setup.exe and inside the bin directory I found the Visual C++ installer. There were two copies:

  • bin\vcredist_x64.exe
  • bin\vc90\vcredist_x64.exe

The latter is the one that was being executed, so I replaced it with the last version (I also had to rename the file in order to replace the Matlab's one).

Now the install went through, but when starting Matlab the Visual C++ 2008 kept popping up asking to install. So I went into Matlab's bin directory (for me it was C:\Program Files\Matlab\bin) and replaced vcredist_x64.exe (which somehow Matlab had overwritten with its copy) with a custom executable which I compiled to do nothing at all.


I've found an article dated 5th May 2016 and it has couple of options to solve your issue:

  1. Install Microsoft hotfix
  2. Remove the updates KB2918614, KB3072630, KB3000988 and KB3008627 do reboot and try installing Matlab again
  3. Edit registry as the mentioned above tutorials suggests, but in a bit other way. You should probably delete everything what's associated with Matlab, reboot and then try installing once again.

The article I'm referring to is related to Autodesk software, but there is a high probability that it could be a universal fix.

Hope this helps.

  • 1
    Thanks for the help. I tried all the options but unfortunately none worked. Those updated aren't listed among the installed ones. I have 5 updates installed and all start with KB31. – rubik May 24 '16 at 9:51
  • @rubik Have you tried to remove all of the 5 updates you currently have? – alljamin May 24 '16 at 12:26
  • 1
    Yes, but only one can be uninstalled. The other ones do not have this option... – rubik May 24 '16 at 15:17
  • @rubik Have you tried to boot into safe mode and uninstall the updates? Run->msconfig->Boot->Safe boot->Ok->Restart – alljamin May 25 '16 at 5:51
  • 1
    Oh no, I did uninstall the updates, but the error persisted. I think I got it working by swapping files. I'll post what I did soon. – rubik May 26 '16 at 7:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.