2

I'm using pulseaudio on my debian system. My PC is connected to a 5.1 system. I enabled remixing, lfe remixing, channels, etc. in the pulseaudio configuration (speaker-test works perfectly). When I play stereo sources (vlc, youtube, etc.) no sound comes from Center and lfe. Looking at the volume meter (pavumeter) shows that only front/rear left/right get volume, center / lfe don't move at all. When I disable remixing, only front gets volume, so remixing itself is working (somewhat).

I'm using the software master volume to control the overall volume, i.e. the 5.1 system is a maximum volume and system volume is at 5-10%. When I turn up the system to 100% (and turning down the hardware volume), more and more sound gets "distributed" to the center/lfe channels (without actually getting any bass from the subwoofer). I tried tinkering with the channel map to no avail. Also, when I open the device in alsamixer and just push the master volume up and down once, all channels are at full volume, but then (in pavucontrol) the center and sub channel is always put at 100% volume and I can't further increase the system volume because one of the channels is already at 100%.

When bypassing pulse and using a simple lowpass filter / split setup in ALSA, everything works perfectly.

It seems that pulse uses the master volume of center and sub as relative volume, whereas the front/rear volumes are used as absolute.

System information:

aplay -l | grep card:

card 0: XFi [Creative X-Fi], device 0: ctxfi [Front/WaveIn]
card 0: XFi [Creative X-Fi], device 1: ctxfi [Surround]
card 0: XFi [Creative X-Fi], device 2: ctxfi [Center/LFE]
card 0: XFi [Creative X-Fi], device 3: ctxfi [Side]
card 0: XFi [Creative X-Fi], device 4: ctxfi [IEC958 Non-audio]
card 1: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
card 2: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
card 2: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]

uname -a: Linux --- 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-2 (2016-04-08) x86_64 GNU/Linux

cat /etc/pulse/daemon.conf | grep -v ";":

enable-remixing = yes
enable-lfe-remixing = yes

# Same effect with = yes
flat-volumes = no

default-sample-channels = 6
default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe

pulseaudio --version: pulseaudio 5.0

  • Okay nevermind. Through immensly clever usage of apt I managed to completely break my system. I'll reinstall when I have time and try again. – incaseoftrouble May 23 '16 at 15:03
1

Try this:

pulseaudio --kill && rm ~/.config/pulse/* && pulseaudio --start

The above helped me work around this issue in Ubuntu 18.04. It's more or less a way to "reset" pulse user-space session config. But it's only a partial workaround because the missing stereo to centre/LFE channel upmix problem re-occurs after the next reboot/gnome session startup.

I suspect /etc/xdg/autostart/pulseaudio.desktop which runs /usr/bin/start-pulseaudio-x11, at the gnome desktop 1st initialization phase, is getting something wrong. All my defaults being appropriately in etc/pulse/daemon.conf.d/01_surround_51.conf:

# 5.1 surround sound
enable-lfe-remixing = yes
lfe-crossover-freq = 120
default-sample-channels = 6
default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe

The above settings were to suite a cheap logitech surround sound system with 3 x 3.5mm analog audio jacks to insert into the HDA sound card outputs where mine was also ALC892.

| improve this answer | |
  • Thanks so much for this answer! I too have these kind of weird issues on 20.04 when waking up from sleep. – m0dular Oct 23 at 2:53
0

Use alsamixer to unmute your other channels. In alsamixer you can select a channel by using the left arrow/right arrow keys and toggle mute/unmute the selected channel by pressing the M key.

| improve this answer | |
  • 3
    If you take out the rant (which you should), you're left with just the name of a suggested product. That doesn't really constitute an actionable solution to the question. I suspect this may attract downvotes. – fixer1234 Jul 30 '16 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.