1

This question already has an answer here:

Initially (just after system startup) the ip table is like that:

192.168.0.0    255.255.255.0         On-link      192.168.0.11    276
192.168.0.11   255.255.255.255       On-link      192.168.0.11    276
192.168.0.255  255.255.255.255       On-link      192.168.0.11    276 

and when i run netcat:

nc -zv -s 192.168.0.11 192.168.0.11 80

to test if port 80 is open it works - the port 80 is indeed open. But when i remove the 192.168.0.11 route i got "TIMEOUT" on nc test. Shouldn't it pick 192.168.0.0 route and work? Moreover when i add the route manually:

route add 192.168.0.11 mask 255.255.255.255 0.0.0.0 it still doesn't work!


Can someone else try to provide me eventually an usefull answer?

marked as duplicate by Daniel B, BlueBerry - Vignesh4303, karel, Jarmund, DavidPostill May 30 '16 at 0:26

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

The system adds the address of the local interface so the routing table should know that any traffic addressed to this IP address it shouldn't be sent out on the network.

  • Yes i konw that but why is't it working when i manually add previously deleted route ? – Mulligan May 23 '16 at 21:34
  • Can You please answer my question? – Mulligan May 28 '16 at 8:14
1

0.0 is a network address and 0.255 is a broadcast address. The only valid actually usable IP address listed there is 0.11.

So no, what you are attempting will not work.

  • but 192.168.0.11 belongs to 192.168.0.0 network so why don't it pick 192.168.0.0 route if 192.168.0.11 is removed? – Mulligan May 24 '16 at 8:25
  • Can You please answer my question? – Mulligan May 25 '16 at 8:42
  • The packets have nowhere valid to go if you don't have at least one working address in that subnet. – Overmind May 25 '16 at 12:08
  • I don't understand. Why do You say i don't have any working address? All i deleted is just a route not just 0.11 interface. – Mulligan May 25 '16 at 16:01
  • Can You please answer my question? – Mulligan May 28 '16 at 8:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.