0

Thanks to The answer of Bob on a question on changing page numbers, I am able to start numbering the pages in my document only after the preface. This means cover page and preface do not get a page number and my introduction gets page number 1. (I did not invent this. This is required.)

However, my TOC still refers the original page numbers, not the ones visible in the footer. Can I change this?

PS: After pressing [Alst]-[F9], my footer reads { ={PAGE}-3} and my TOC reads { TOC \o "1-3" \h \z \u }

2 Answers 2

1

To use a "normal" Table of Contents that generates the page numbers itself, the numbering and formatting comes from the settings in the "Format Page Number" dialog.

So to do it this way, the page numbers have to start at 1, not at 4.

In order to achieve that, you need to ensure that there is a section break (Layout Tab->Page Setup group->Breaks dropdown) before your Introduction.

Then you can go into the Header/Footer for the section, choose Design Tab->Header&Footer group->Page Number dropdown->Format Page Numbers..., then set Page Numbering to Start At 1.

You can then change your page numbering field from

{ ={PAGE}-3}

back to

{ PAGE }

However, if you also need another numbering sequence (as in the question you reference), you can calculate that one from { PAGE }, e.g. if you need Roman numbering on page "1" to start at IV, you can use

{ ={ PAGE }+3 \*ROMAN }

If you are also using { NUMPAGES }, e.g. in page numbering such as

Page n of m

then you may need to use a calculation to modify the value of NUMPAGES, e.g.

{ ={ NUMPAGES }+3 }

but I cannot tell from the question as it stands.

0

I think the TOC adopts the formatting (and page numbering) of the PAGE field. So I think you just need to reverse the setup of your fields (so that the header is the calculated field instead of in the footer).

In the footer will be the actual page field. Format this via the Format Page Numbers option of the Page Number button in the Header and Footer section of the Design ribbon so that:

  • the Number format is set to I, II, III...
  • Page numbering is set to Start at VI

So the field in your footer will look like {PAGE \* ROMAN \* MERGEFORMAT } (ie it's just the PAGE field, no calculation).

Then use the equation field in your header instead: { = { PAGE \* ARABIC }-5 } The ARABIC switch converts the roman numerals back to Arabic (ie 6) so that you can use it in calculations (eg 6-5=1) (otherwise you'll get an error undefined bookmark).

Now the page numbers in your TOC will be VI, etc as that is how the PAGE field in the footer is formatted.

1
  • My question is not the format, it is about the numerical value. May 24, 2016 at 5:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.