I get this error when i want to run the following command: pure-pw list

Unable to open the passwd file: No such file or directory

I remove manually the folder /etc/pure-ftpd/ and I think this is the root of the problem. So i tried to regenerate it by reinstalling pure-ftpd, but i still don't have this folder.

Do you have any idea how to solve this issue?

Thanks a lot

  • 1
    Which error are you referring too..
    – AReddy
    May 24, 2016 at 9:21
  • @Mongrel it's written in the title May 24, 2016 at 9:28
  • @Mongrel just edited May 24, 2016 at 9:29

3 Answers 3


For those with same trouble in Red Hat or Centos default yum installation.

  1. Open /etc/pure-ftpd/pure-ftpd.conf, uncomment line above

    #PureDB                        /etc/pure-ftpd/pureftpd.pdb
  2. Create the passwd file

    touch /etc/pure-ftpd/pureftpd.passwd
  3. Restart Pure-Ftpd service or create the database file

    systemctl stop pure-ftpd; systemctl start pure-ftpd


    pure-pw mkdb -F /etc/pure-ftpd/pureftpd.pdb

Now you can create your ftpusers.


If you definitely have created a user with:

pure-pw useradd

Then try linking your files and restarting pure-ftpd:

sudo ln -s /etc/pure-ftpd/pureftpd.passwd /etc/pureftpd.passwd
sudo ln -s /etc/pure-ftpd/pureftpd.pdb /etc/pureftpd.pdb
sudo ln -s /etc/pure-ftpd/conf/PureDB /etc/pure-ftpd/auth/PureDB
systemctl restart pure-ftpd

Guide on a complete setup for ubuntu. https://help.ubuntu.com/community/PureFTP


Use this, I have the same problem and I have solved it.

apt-get --purge remove pure-ftpd-common

apt-get install pure-ftpd-common

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.