2

I made a fresh install of Debian today and now I am trying to install the SSH server so i can connect to the machine remotely.

When I do apt-get install ssh it shows me that packages cannot be installed. Going down the line trying to install dependencies manually, I did get to the point where it requires the package libedit2(required by openssh-client, which is a dependency for server and so on).

Doing apt-get install i got the following message:

Package libedit2 is not available, but is referrer to by another package. This may mean that the package is missing, has been obsoleted or is only available from another source.

I checked the online package search and it looks like the package exists for Jessie. After that I checked the sources.list and had these lines there:

deb http://security.debian.org/ jessie/updates main
deb http://ftp.uk.debian.org/ jessie-updates main

I didn't see a main repository(only updates) which the packages should probably be located in, so i added this:

deb http://ftp.debian.org/debian jessie main

After that i expect the packages to be found and installed but when i did apt-get update i received an error:

Failed to fetch http://ftp.debian.org/debian/dists/jessie/main/binary-i386/Packages 404 Not Found [IP: 130.89.148.12 80]

I am using an old AMD Athlon XP, this is why it has the x86 version installed and the i386 repositories are being checked.

Please help me fix the issue installing SSH. If you need any additional information, i will provide it.

Edit: I was trying to apt-get update whole morning when i wrote this question and i received and error stating the Packages were not found on the server. Now i did update again and everything completed successfully. After that I was receiving a hash mismatch error when trying to install SSH. I waited 30 more minutes, tried again and SSH installed. I have no explanation what happened.

  • Did you tried openssh-server. apt-get install openssh-server. – vembutech May 24 '16 at 9:48
  • That's a little odd; the expected URL would be http://ftp.debian.org/debian/dists/jessie/main/binary-i386/Packages.gz (note the .gz at the end). Not sure why your system is trying to grab the URL it's trying to, but I would start looking there. – a CVn May 24 '16 at 9:52
  • @vembutech , yes, when i try to install only openssh-server, it's dependencies cannot be found in the packages – Milen Georgiev May 24 '16 at 9:55
  • @MichaelKjörling , the strange thing is that contrib works but main shows the 404 error – Milen Georgiev May 24 '16 at 9:56
  • When was the last time you've done apt-get update? – grawity May 24 '16 at 10:09
1

It turned out that my router was using crappy firmware and my network traffic was corrupted most of the time when using cable connection. I updated the router to the latest official firmware and now everything is working just fine.

0

Can you try #aptitude install openssh-server Because, I have seen most of the times #aptitude work for me where #apt-get gives a dependency related error.

Also find some wiki info here [https://wiki.debian.org/SSH].

  • I don't have aptitude installed and i have the same problem installing it too - missing package but referenced in another package. – Milen Georgiev May 24 '16 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.