10

I need to associate a specific application for a .mus file type on a Windows 10 PC.

NONE OF THE ANSWERS INVOLVING THE "OPEN WITH" OR OTHER CONFIGURATION EDITORS WORK.

This is because the .mus file type does not appear on the list of file extensions, AND (even though the application is associated with other file types) the application does not appear on the list of applications when trying to do this by application, rather than by file type.

This is driving me nuts. Right-clicking on such a file and choosing "Open With" will show the correct application, but it does NOT contain a check box for "Always use this..." Instead, "open with" has opened some (IMHO) piece of junk called "File Association Helper" that Winzip decided I could not live without. It has a "Never ask a about this file type" checkbox WHICH DOES NOT WORK.

I just want to be able to double-click on a .mus file and have the correct application open it. This should not require wading knee-deep in the registry in order to fix this.

Does anyone have any ideas at all how to register a new file type IN WINDOWS 10?? The instructions I have found do not match the registry keys I can see on Win 10.

  • In windows 8: Right click a .MUS file, select Open With..., check the box Use this app for all .mus files, select More options, scroll to the bottom and select Look for a another app on this PC and navigate to the application that should be the default. This doesn't work in Windows 10? – DrMoishe Pippik May 24 '16 at 19:59
5

You should be able to do the following

  1. Open File Explorer (right click Start -> File Explorer)
  2. Find the file you want to associate
  3. Right click the file and select Properties
  4. In this window click Opens With
  5. Select the program you want to open this file

File properties Dialog

Note that this dialog box tries to guess what program to use. Sometimes it's very wrong. I had to scroll down, select More Apps, and then scroll down again and click Look for another app on this PC before it gave me a file explorer to look for files.

  • Machavity: Thanks. This did not actually SOLVE the problem, but it did get me around the dumb "File Association Helper." After trying your solution, the next time I tried to open this file, it presented me with the MS default file association box, and again asked which application I wanted to use. It DID have the correct option for using this application for all .mus files. And that worked. Thanks again. – Joe Begenwald May 24 '16 at 20:13
  • 1
    This solution did not even fix it for me, as it was impossible to change the application to something else than "choose an application dialog". See my solution below which fixed my issue. – gaborous Oct 24 '18 at 21:23
9

If all else fails, you can try to resort to commandline manipulations:

  • Open cmd.exe with administrator rights (right-click on the shortcut to get this option)
  • Type ftype extfile="C:\Program Files (x86)\YourProgram.exe" "%1" where you replace the path with the executable of the program you want to use to open by default this extension (make sure to keep the "%1", this will get replaced dynamically to point to the file you're double-clicking on) and optionally replace extfile with a name of your choice to describe the type of file you're trying to open. Then press Enter.
  • Finally, type assoc .ext=extfile where you replace ext by the extension you are trying to associate and extfile with the name you chose above, then press Enter.

After this, you should normally be able to open the files by double-clicking. The filetype icon will change on the next OS reboot or after reopening an explorer window.

If you have multiple file extensions for the same filetype (eg, .ext2) that can be opened with the same program, then you can simply redo only the last step, eg: assoc .ext2=extfile. In this case, both ext and ext2 files will be opened with YourProgram.exe by double-clicking.

  • 1
    Thanks, wasn't able to associate .h264 files to VLC using the chosen answer or anything else I found. This one worked right away. – Bazul Nov 9 '18 at 19:55
  • 1
    @Bazul yes it's ridiculously difficult in Windows 10 to associate a filetype with a program. Because the program first has to register in the Windows Registry that it can open this filetype, else Windows will not even allow to open files by default with this program, whatever the user might choose. – gaborous Nov 10 '18 at 18:06
  • This solution worked for me on Windows 10. Thanks! – Tadej Nov 20 '18 at 18:52
  • 1
    This solution worked when I realised that the commands were entered in two separate steps rather than one step. Could you edid the answer to say "press enter" after step two? This wasn't clear to me and I nearly gave up. – Kit Johnson Nov 29 '18 at 4:01
0

To associate a custom-built app to the file, put a shortcut for the app on your desktop, then browse to the desktop when you use "Look for another app on this PC."

  • Please clarify what you are trying to convey to people as it's not 100% clear what you are suggesting... Sure creating a shortcut is simple enough but clarify or add screen shots or specific instruction for the other portions you talk about to help clarify your answer. – Pimp Juice IT Aug 11 '17 at 23:41
0

Create a file on desktop, it can be left as new text document, change the extenson to anything. Eg (.my,) Now right click on the file U wish to change to NO ASSOCIATION choose properties, then change then more apps scroll down to choselook for another app, Click desktop in left menuthen change the box above open to All Files(,) then pick the text document U created from above list & click open. The file U created on desktop can be deleted leaving the file U want no longer associated to anything

protected by Community Apr 27 at 19:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.