I have several search folders setup in Outlook 2013 that look for particular subjects in an e-mail that arrived either today or yesterday. (Our email provider is MS Office 365, for what its worth). Search Terms

Advanced Search Terms

The problem is that when I go into the search folders today, I can see that I've received emails that match this search in my inbox, but they don't appear in my search folder. E.G. Today is Wednesday and there are no emails from Wednesday. However, the search folder does display emails from Monday and Tuesday. It seems to think "today" is Tuesday, even though it is Wednesday. I restarted the machine + outlook and neither seems to have solved the issue.

Does anybody have any idea what might cause this behavior? Or perhaps a way to force it to update the search?

Update: The search folders work "properly" on another machine with the same operating system (both Win 7), but still don't work on another. It doesn't seem to be a time zone issue, the email account on Outlook 365 is correct (EST) and both machines clocks are correct.

  • Time zone set right? DST? – Ƭᴇcʜιᴇ007 May 25 '16 at 14:13
  • Yes, everything time/date wise looks fine on the machine. It shows the "correct" time on both the Windows clock and also when the exact same search is done manually, it returns the correct results. – mkingsbu May 25 '16 at 14:15

This is a combination of what criterias Outlook 2013 uses when performing a search in different parts of Outlook 2013. If you are subscribed to Office 365, you have some defaults you need to review so search as it relates to time is more consistent. It is just bad user experience by Microsoft once again.

Change the time zone to the correct setting in Outlook Web App.

To do this, follow these steps:

  • Sign in to Outlook Web App
  • click Settings
  • click Options.

In the left navigation pane:

  • click Settings
  • click Regional.

In the Current time zone box:

  • click the arrow
  • click the correct time zone setting.
  • click Save

Source KB 2298834

  • The time zone setting appears to be correct (EST). It looks like when we use another machine with the same client and same operating system, it works on that system but still not on this one. I'll update the main question to also reflect this. – mkingsbu May 25 '16 at 16:53
  • Make another custom search entry. I don't have a problem creating a custom search looking for a keyword with Received today and Received yesterday entries. Seems like a localized issue then. You can also try using just one Received - on or after - yesterday. Worst case, do a Office repair, or Uninstall and New Install. – Sun May 25 '16 at 17:21
  • Thanks, I'll probably try a reinstall tomorrow if the problem isn't alleviated by itself. Really odd error, never seen anything like it. – mkingsbu May 25 '16 at 17:53
  • The other thought was to rebuild your index – Sun May 26 '16 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.