Before I start, my /etc/fstab file has the line:

// ~/Desktop/Atkins cifs rw

Ubuntu is giving me strange issues. I'm trying to mount a directory, so I type:

sudo mount //

which returns:

Couldn't chdir to ~/Desktop/Atkins: No such file or directory

(I do know this folder exists btw.) So to be sure, i try to create it again with:

mkdir ~/Desktop/Atkins

Which returns:

mkdir: cannot create directory '/home/classroom/Desktop/Atkins': File exists

So basically, the computer is simultaneously convinced the folder exists, but can't map a network share to it, because it doesn't... Deleting and re-creating the folder doesn't fix it.


~ is resolvable in your shell but mount has no idea what it means to the shell and to you. Use full path.

The command like

sudo mount -t cifs -o rw // ~/Desktop/Atkins

should work because the shell expands ~ and passes full path to mount. Yet if mount reads its arguments from /etc/fstab then it treats ~ literally as a part of the target path; hence no such file or directory.

| improve this answer | |
  • awesome. This did fix that error. Maybe this is a quick answer, but maybe i'll have to open another thread. Now it asks for the password for root@// The share does not have a password, and just hitting enter doesn't work. What to do? – Blaine May 27 '16 at 9:46
  • 1
    According to this man page you need guest option. Try rw,guest instead of just rw in your /etc/fstab. – Kamil Maciorowski May 27 '16 at 9:57
  • tried that. now I just get a mount Error(13): Permission denied – Blaine May 27 '16 at 9:59
  • We are going off topic. Maybe you can access the share with user=<right_name_here> option. It depends on server (and share) configuration you should know. – Kamil Maciorowski May 27 '16 at 10:04
  • ah well, that doesn't work. Looks like it will be lengthy. I will open a new thread if I can't figure it out. Thanks for all the help – Blaine May 27 '16 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.