7

I installed my brand new Lenovo 900s and after installing my standard software and development systems and suddenly the system wouldnt boot and is stuck in the boot screen. I first thought it was defective and rebooted, tried repairing the UEFI bootsector and so on to no avail. By chance I left it stuck in the boot screen while I talked to a collegue and when I came back to the machine I could log on.

I then discovered that it takes between 10 and 20 minutes for the machine to boot. I ran the performance toolkit and found that it is stuck in the Wininit phase but I coud not find out which particular process or driver is causing that.

What I already tried:

  • sfc /scannow
  • dism restorehealth
  • Windows 10 inplace upgrade
  • Uninstalling Bluetooth and Audio, reinstalling
  • Updating all drivers
  • Cleared Appcompat cache

This is the picture of the boot phases:

Performance analyzer boot phases view

[1]: http://i.stack.imgur.com/8l14W.jpg

Edit 1: When I load the ETL in performance analyzer with the Fullboot.boot profile I can see that the running processes in that phase are ntoskrnl.sys, cdd.dll, cxkrnl.sys, win32kbase.sys and dxgmms2.sys. Maybe this has to do with directX? Also there is nearly no CPU/Disk activity in the complete phase.

Edit 2: I did a logged start. ntblog.txt states cdrom.sys is not loaded (makes sense as there is no cdrom), four times (spread across the log) dxgkrnl.syss ist not loaded and near the end wdFilter.sys is not loaded. DXDIAG did not find any problems. In device manager there are no warning signs.

Edit 3: As the cdd (canonical display driver) was involved in the phase of interest I uninstalled the Intel 550 display driver with the option to remove the files. The effect was a shorter delay between the usual logo phase and the “comes back" logo phase on reboot. Eventually the display is initialized before the problem and more likely not the cause.

Edit 4: I reran boot monitoring with more options and could open the generic events view. I can only see only System and Idle active in that phase with several subprocesses but nothing that really helps as the events are spread across the 700s timeline.

Edit 5: Just to be sure I reset Windows Update (stopping services, renaming Software distribution folder, restarting services). No change after rebooting...

Edit 6: I decided to go the painful way of reinstalling my complete stuff (which is quite a bit as I am a developer) especially because it is the second time. I will now go back to an very early image that worked and set restore points before every mayor installation step and reboot after. Once I discover the cause, I will post it here.

Update 1: I did a complete reinstall with all applications except STEAM with system restore points and rebooting after every step and - booting and restarting keeps at 10s! I will now make two images, run bitlocker and then try steam (with a restore point before). Pray ;-)

Last Update: I encrypted C: and D: with Bitlocker and installed Steam. Everything works fine. The only difference to the previous two installations that lead to the 10-20 minutes boot was Photoshop CS2. But I installed it checked reboot, worked and deinstalled it again as I use Corel Photopaint now. I have no Idea what caused the problems on the one hand and I am a happy owner of a running 900s now on the other.

  • Do you have Lenovo fast boot on in the bios? – NetworkKingPin May 27 '16 at 11:22
  • Yes. Also I tried with off, with fast boot in windows off etc. All this does not make a difference. The SSD is a NVMe 512GB (very fast). – MichaSchumann May 27 '16 at 11:26
  • Now boot screen is this past the bios? and is the actual windows boot logo it is stuck at? – NetworkKingPin May 27 '16 at 11:34
  • Unfortunately Lenovo only shows the word LENOVO and the loading animation. It appears immediately after swithcing on and usually disappears after about two rounds - being replaced by the Windows login screen. In my case it also disappears but comes back and stays there. As you can see in the performance view, the delay is definitively after Bios as it is the WinInit phase. – MichaSchumann May 27 '16 at 11:40
  • Windows 10 and the phrase "suddenly [ insert something unexpected ]" have become synonymous. – DeathByTensors May 27 '16 at 11:53
1

The WinLogonInit phase is slow.

What Happens in This Subphase
The WinLogonInit subphase begins when SMSSInit completes and starts Winlogon.exe. During WinLogonInit, the user logon screen appears, the service control manager starts services, and Group Policy scripts run. WinLogonInit ends when the Explorer process starts.

Visual Cues WinLogonInit begins shortly before the logon screen appears. It ends just before the desktop appears for the first time.

WinLogonInit Performance Vulnerabilities Many operations occur in parallel during WinLogonInit. On many systems, this subphase is CPU bound and has large I/O demands. Good citizenship from the services that start in this phase is critical for optimized boot times. Services can declare dependencies or use load order groups to ensure that they start in a specific order. Windows processes load order groups in serial order. Service initialization delays in an early load order group block subsequent load order groups and can possibly block the boot process .

After applying the FullBoot.Boot.wpaprofile go to the Generic Events - Generic Fullboot table and expand the Microsoft-Windows-Winlogon provider, look for the tasks that belong together (same taskname but 1 Event with Start and 1 with Stop Opcode) and look at the time column and subtract the starttime from the endtime to get the entire duration. Now the task is very long.

In the sample, RequestCredentials (entering password) and AuthenticateUser (checking typed in data) takes too long.

enter image description here

  • Thanks, I followed this advice (that - I think you gave an other user too) but as I said there is no process identifyable that causes it. Only Idle and System are running in that phase. As we are talking about more than 10 minutes (700s) in that phase without any noticable CPU or DISK or MEMORY activities, it ist something ery strange. I believe a faulty registry entry is causing one of those processes to wait for a condition with a huge timeout. However - falling back to the working image gave me back about 15s bootup time... – MichaSchumann May 28 '16 at 10:19
  • share the ETL (compressed as 7z to reduce the size to upload) and I'll take a look at it. Maybe this helps you to avoid getting the issue again. – magicandre1981 May 28 '16 at 15:35
  • Thanks for the offer, I already archive it and did a complete reinstall - see above. – MichaSchumann May 28 '16 at 16:17
0

It seems Windows 10 forgets about the status of a setting when there are some changes to the installed apps. Trying this will resolve that:

1. Start button -> type "choose a power plan" -> open Choose a Power Plan

enter image description here

2. Click "Choose what the power buttons do"

enter image description here

3. "Turn on fast start-up" may be checked or not.

a) If it is already checked then click "Change settings that are currently unavailable" and uncheck it and save and Shut Down(not restart) and boot PC. After restarting check this setting and save again and Shut Down(not restart) and boot PC.

b) If it is not chekced then click "Change settings that are currently unavailable" and check it and save and Shut Down(not restart) and boot PC.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.