14

I am accessing a remote machine by VNC Viewer. Sometimes I find I can't copy and paste text from VNC Viewer.

1
  • Both the VNC server and VNC viewer need to support the shared clipboard feature. I assume you are using VNC Viewer (RealVNC), so make sure you are connecting to a VNC Server (RealVNC). – juniorRubyist Jan 6 '19 at 4:41
10

None of the posted answers worked for me. vncconfig wasn't installed and other posts indicates that those fix only helped when c&p worked in the past. This was not the case for me on a fresh machine.

Using tight vnc server on a Raspberry Pi 3, I had to install autocutsel:

sudo apt-get install autocutsel

add the following line to ~/.vnc/xstartup:

autocutsel -fork

My complete xstartup file now looks like this:

#!/bin/sh

xrdb $HOME/.Xresources
# -solid grey gaves us a real mouse pointer instead of the default X
xsetroot -solid grey -cursor_name left_ptr
# Allow copy & paste when ClientCutText is set to true on the client side
autocutsel -fork

export XKL_XMODMAP_DISABLE=1
/etc/X11/Xsession

To apply the changes, restart VNC server:

vncserver -kill :1
vncserver :1 -localhost -geometry 1400x1050

Adjust the parameters according to your needs (display, resolution, ...) Now make sure that the property ClientCutText is set to true on your client. In real vnc viewer, open the properties and choose expert tab.

Now copy and paste works for me :)

5

If you can't copy & paste text, first check if you run "vncconfig &".

If you still can't, check terminal number n and run "vncconfig -display :n &".

Hope this helps.

3
  • 2
    It's unintuitive that the vncconfig program that shows up is necessary for copy and paste. I closed its window thinking, "I don't need to change my settings." Then later I noticed that copy and paste wasn't working and wondered why. Running vncconfig & fixed it for me. – Brent May 13 '20 at 17:10
  • Where should you enter this command? On Windows? On Mac? – testing Aug 27 '20 at 10:27
  • Linux terminal, didn't try Mac. – Fisher Sep 2 '20 at 11:03
4

well this is what worked for me :

all i did is open VNC using "Run as administrator " and I was able to copy paste from windows 10 to Mac over VNC

0
1

If you're having problems pasting from windows client to a remote mac, do remember to use the appropriate keyboard shortcut - alt+v (translates to +v) instead of ctrl+v

This may be obvious for some, but less so for others

0
  • Create a shortcut of your VNC viewer
  • right click it, than properties
  • in the target, add -clientcuttext=1

example: "C:\Program Files\RealVNC\VNC Viewer\vncviewer.exe" -clientcuttext=1

7
  • 1
    Seems it's one way copy. Copy text from VNC to Windows is working. But can't copy Windows text to VNC. Thanks! – Fisher Feb 8 '17 at 12:26
  • After remove "-clientcuttext=1", I can copy text from Windows to VNC. – Fisher Feb 23 '17 at 13:55
  • @Fisher ClientCutText - Specify FALSE to prevent a connected VNC Viewer user pasting text to the VNC Server computerso it must be set to true. There might be some other issue preventing you from copy/paste-ing. For example the copy/paste feature can be disabled from the vnc server to allow or disallow for different users. Maybe this will help: realvnc.com/docs/copy-paste-text.html – Divin3 Feb 23 '17 at 14:52
  • Now copy/paste from or to VNC is working perfect. So I don't think server has disabled copy/paste feature. Basically "-clientcuttext=1" can cause problem. Thanks! – Fisher Feb 24 '17 at 13:56
  • @Fisher - my theory is that the server could deny the copy/paste feature depending of the username that you used to connect – Divin3 Feb 24 '17 at 14:09
0

In windows:

cmd
C:\Program Files\RealVNC\VNC Viewer\vncviewer.exe

Run this way, you can copy from both sides.

Run this way,

C:\Program Files\RealVNC\VNC Viewer\vncviewer.exe -clientcuttext=1

from vnc server to windows client is available.

0

The other autocutsel answer was almost the answer for me, but not quite. What works for me is:

autocutsel -f -s PRIMARY

I'm running vnc4server 4.1.1+xorg4.3.0-37.3ubuntu2 on xenial and tigervnc-viewer 1.10.1+dfsg-3 on focal

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.