2

After freshly installing Avast Premier on a brand new HP ProBook 470 G2 with Windows 10 Home, I keep on getting the following message that prevents Windows from booting normally:

The operating system couldn't be loaded because the digital signature of a file couldn't be verified. File: \Windows\System32\Drivers\aswVmm.sys Error code: 0xc0000428

The workaround is to pres F8 and 7 - Disable driver signature enforcement in startup options.

I have tried:

  1. Repair AVast
  2. Uninstall - boot - download - Install Avast

This did not help. Looked on the internet, like here, but no reasonable advice. (I have copied the original disk to SSD with Samsung Data Migration software, which was a seamless process.)

Any workaround except disabling driver signature validation?

3

It appears that the file aswVmm.sys does not have WHQL signature in the present version (2016 11.2.2262), it can be verified by running the sigverf tool. When secure boot is enabled it requires that all drivers are WHQL signed as specified here. So you need to disable secureboot in BIOS to get it working.

Another recommended fix:

  1. turn off the self-protection module (UI / Troubleshooting)
  2. run regedit.exe
  3. in HKLM\System\CurrentContolSet\services\aswVmm set Start=4.

Hope this is going to change in future releases.

  • I used the recommended registry editing solution using AVG rescue cd in usb mode at boot time and it worked fine for AVG. Thanks... – Rohit Gaikwad Jul 8 '17 at 18:04
0

The workaround you have listed here didn’t work in the case of the computer that I just had to repair for somebody. First in the start up system repair I had to go to command prompt and disable the auto repair because it was stuck in a loop. Then I was able to figure out that it was the avast System driver that was the issue. Then I had to use the command prompt again in order to manually delete the driver. Once that was done I was able to get right onto the computer without an issue and checked it and couldn’t find anything that could’ve corrupted it. They had it happen after an update. Avast tried to tell them they had to wipe their entire computer and redo the whole OS. They have been having this issue since at least 2014 that I found online so they should know how to fix this by now. With this issue the computer could not start, could not start in safe mode, and trying to do the other things that you suggested did not work. I even created a USB from Microsoft in order to try to run the repair from that and that did not work. The only thing that worked is what I stated in the beginning.

-1

looking at where the issue is your pc may have come with a missing file from system 32 which is where all the information for the OS, startup sequence, and everything else that helps run the computer is located. error code 0xc0000428 means there is a missing file in system 32 and you may have to get it repaired at a computer store or something.

  • This is completely useless and false - there is no file missing. – Vojtěch Dohnal May 27 '16 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.