1

My issue is that I've been unable to have the terminal command sudo apt-get upgrade to not run on the proxy. I've tried unset {http,https,ftp}_proxy and unset {HTTP,HTTPS,FTP}_PROXY to no avail. I've also tried to set the proxy settings to none in the network settings, but it too, didn't work. Basically I would like to totally remove the proxy server from all of my settings. Sorry for being such a novice user.

In addition, the main reason why this problem is that I haven't been able to update my computer at all, or get new software from the command line. I would appreciate any and all answers that help resolve this.

If it helps, I'm running Linux Mint 13 Maya. In addition, from terminal, when executing those commands I get 0% [Connecting to www.hidemyass.com (proxyip)], yet the web browsers say that I'm not behind a proxy.

1

It depends how you configured your proxy in the first place.

You could check if you previously specified the proxy settings in an apt config file, using this:

grep 'https*::Proxy' /etc/apt/ -i -r

Alternatively, if your proxy settings were placed in /etc/sudoers then you can't disable them before running sudo. You should either run sudo visudo to remove the proxy config, or disable the settings temporarily like this:

sudo su -
unset {http,https,ftp}_proxy
apt-get upgrade
  • With the grep command, it listed settings within /etc/apt/apt.conf. Should I delete all lines with Acquire::{http,https,ftp}proxy? or should I just leave the " " 's blank? – Unnameduser May 28 '16 at 16:01
  • You could delete them. But I would just comment them out by putting // at the front of the line. – joeytwiddle May 28 '16 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.