0

I had to replace the CPU fan and the inverter cable of this macbook.

I followed the guides at ifixit: Repair guides for MacBook Core 2 Duo

After reassembly the screen and the fan worked properly but many programs are incredibly sluggish now. For example if I move the cursor along the Dock, it stutters. Typing here is like waiting for the text coming out of a telex. Graphics in certain windows is garbled in very few cases. E.g. youtube frames in Opera.

CPU Temperature is usually low, but with load it rises instantly over 80°C while the heat sink stays at 60°C. The sluggishness seems not to be directly connected to the temperature, as this behaviour is also apparent before the CPU temperature rises.

The steps of repair included many mechanical steps and dis- and reconnection of cables.

I had one complete system crash (famous "you have to restart your computer ") since then, but I had those earlier once in a while, so I don't consider it significant yet.

When running "top -o cpu" the task "WindowServer" eats easily 50% or more of my CPU when I'm typing or performing other tasks.

The mac has a 320 GB SSD (only 9 GB left :( ), 4 GB Ram. Running Mac os 10.7.5

Which possible sources of my problems do you see? And which do you favour?

  • Bad connection after reseating of connectors?
  • Damage of solder joints due to mechanical stress?
  • loss of thermal contact to heat sink due to old grease in combination with mechanical stress?
  • Problem unrelated with the repair.

What are the next diagnostic steps you suggest? Are there any things I should try first to ease my problem?

1

If you're running OS X Yosemite, the problem with the CPU use with WindowServer is most likely a flaw in the OS itself, as http://osxdaily.com/2015/04/06/windowserver-high-cpu-usage-mac-os-x/ has said. In addition, WindowServer has been known to cause spikes and in-general causing Yosemite to be sluggish. That article should be able to guide you to fix the sluggishness. If the heating also doesn't stop, it may be something lazily coded within the BIOS (CPU temp very hot in BIOS but okay in RealTemp/Speedfan) and it's been suggested to go to idle.com. Hope I could help!

It's also been reported that Lion has had issues with the disk and disk permissions needing repair. After being repaired, a indexing has fixed lion from being so slow. https://discussions.apple.com/thread/3203965?tstart=0 Hope this helps.

| improve this answer | |
  • Sorry, forgot to mention, I'm running Mac OS Lion (10.7.5). Is it even possible to run Yosemite on this device? Even 10.8. refused to install on my mac (too old). – Ariser - reinstate Monica May 28 '16 at 15:26
  • Try looking for errors in the console for when it slows down, it may provide a clue. Also, do you have "My Living Desktop"? – Unnameduser May 28 '16 at 15:40
  • No, no living desktop. Everything's dead. – Ariser - reinstate Monica May 30 '16 at 7:31
1

It is possible that a temperature sensor is bad or not connected properly, or perhaps some other problematic hardware. Next step would be to run AST or ASD on the device.

| improve this answer | |
  • I ran AHT, but it didn't reveal any hardware problems. What could I do next? – Ariser - reinstate Monica Jul 24 '16 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.