I have just built a new computer from parts. Whenever I resume from any sleep mode (S1, S3 or S4) the computer freezes within about 60 seconds of the welcome screen appearing. At this point the computer is completely non-responsive and the only recourse is to reboot.

I have updated the BIOS and all drivers to current from the motherboard manufacturer's site. I have reset BIOS settings to default, including disabling AMD Cool n Quiet.

The windows event logs are not helpful at all. Other than immediately after resuming, the system has been absolutely stable for a couple of months (as long as AMD CnQ is disabled; with Cool n Quiet active I did experience periodic freezes).

The system is:

Mobo       : MSI 790GX-G65
CPU        : AMD Phenom II 965 BE at 3.6 GHz
Memory     : Corsair DDR3 1600, at 1333 MHz and 9-9-9-21
HDDs       : 1 EIDE (System - O/S, Programs, etc), 2 SATA in RAID-0 (Data)
DVD        : 1 LITE-ON DVDRW SOHW-1673S
Card Reader: 1 multi-card reader

Keyboard is attached via PS2 and mouse is USB.

Any thoughts or pointers would be most welcome.


It appears that the computer may not freeze if a program is left running which puts it under significant load. I left a stress test running which keeps all cores under 85% load, and my son put the computer to sleep - while this program is running it I have been able to resume from S3 successfully 9 out of 10 times, compared against about 20 tests with the computer idle which have all frozen. So this may be related to being in an idle state when it resumes.

  • Is your OS on RAID? And which windows is it? – r0ca Feb 12 '10 at 22:09
  • @r0ca: The O/S in on the single EIDE disk, the two SATAs in a RAID-0 config contain only data. Updated the title with the O/S (XP SP3) – Lawrence Dol Feb 13 '10 at 1:17
  • It might be better to post your solution as an answer (which is acceptable BTW). – ChrisF Mar 30 '10 at 21:40
  • @ChrisF: I did this and my answer cannot be accepted; presumably because the expired bounty has canceled the ability to accept an answer. – Lawrence Dol Mar 30 '10 at 22:43

As suggested in the other thread, you can configure (slightly different way for USB keyboards) and use a method to manually force a BSOD to dump the memory to investigate and find out what the heck is hanging your system (*now with great, though kind of lengthy video to help!*—requires SilverLight).

Since your problem is coming out of resume, one thing you could try is running BootVis, and doing a trace of the Next Standby & Resume. Then you should be able to clearly see what is causing the problem—likely one of the third-party drivers is getting hung. (Microsoft has long since removed the file download for BootVis from their sites since people were incorrectly using it to try to speed up or “tweak” their systems instead of using it for what it was actually designed for. However the last known version,—aka the leet version—is still available around the Internet.)

  • This resolved my problem by using crash dumps. Would accept it if I could; have posted a request on meta to change this no-accept-after-bounty behavior. – Lawrence Dol Mar 30 '10 at 21:25
  • I’ve updated the link on the Sysinternals forum and made a note for the video. I’ve also explained about BootVis. I downloaded and compared the version available on SoftPedia and it is identical to the copy I got way back when from the Microsoft site. – Synetech Mar 31 '10 at 12:49

I have identified and resolved my problem. What I did was follow Synetech inc's advice.


  1. I enabled manual crash dumping using CTRL-SCROLL-SCROLL.
  2. I downloaded the WDK debugger from Microsoft's web site tools and installed them (by extracting the debugger installer from the WDK ISO).
  3. I resumed my computer 4 times to where it became non-responsive and crash dumped each time.
  4. Using WinDbg to examine the dumps I noted that in all 4 dumps, 3 of my cores were in the Windows idle function, while the 4th was always in tscomm trying to acquire a spin-lock.
  5. I searched my Windows directory and found tscomm.sys. The properties on tscomm.sys identified it with TamoSoft.
  6. Since I have TamoSoft CommView 5.0 installed I first tried disabling its TCP stack hooks without success. Finally I uninstalled CommView and my problem was resolved - successful resume from S3 sleep.

I have yet to test resume from S4 hibernate, but expect it to work because it hangs in the same place and manner as S3. Hibernate works wonderfully also.

My thanks to "Synetech inc" for not only a fix, but the information needed to debug resume failures in the future.


My guess would be to first understand the problem more intimately. You can increase the memory for a crash-dump, for instance, so you can get more information from your kernel-debugger.

The second thing you have is to do some alleviation of the symptoms. Disabling CnC in your BIOS, and disabling all other features related to clock control might be a good start. See if your PC correctly resumes from S3 now.
Related to this could be to unplug any and all USB devices you may have attached. They have been known to mess up the boot of some systems, they might interfere with wake-up, too. Of course, also try to unplug your mouse and try a PS/2 one instead.

Thirdly could be, after you have tried all previous steps, to do a clean install of your windows, using an official (thus guaranteed clean) disk. If your PC still does not correctly wake from S3, I would be inclined to call tech-support for your motherboard and see what they make of it. You might get, for example, a 'beta' BIOS which supports it. This is unlikely, though, because you are using an old OS.

  • Since it doesn't "crash", per se, since it freezes, I don't think there is any crash dump. Where would I look? – Lawrence Dol Mar 29 '10 at 18:58
  • I will try unplugging all USB devices, but long term the mouse must be connected and I only one PS/2 keyboard/mouse connector so I have to have either my keyboard or my mouse as USB. – Lawrence Dol Mar 29 '10 at 18:59
  • I have been trying to avoid needing to do a clean install, since that's another day out of my life I'll never get back. – Lawrence Dol Mar 29 '10 at 19:01

I cannot say for sure on your motherboard, however, I had similar issues with an Asus motherboard.

I diagnosed by using Microsoft / Sysinternals Process Monitor and Autoruns. I ran Process Explorer, clicking on one of the four graphs at the top to bring up the history window and then entered sleep mode and resumed, I noticed that Asus's own under/over clocking power saving utility was taking up 100% cpu and was thrashing the disk doing something. I then used Autoruns to disable all Asus services to test and it was what I expected.

I hope this helps you and you are able to find out the cause of the delays. As I said, I cannot say for sure on Asus, but it most likely is something similar.

  • I usually don't stay alive long enough to get logged back on after resume... but I vaguely recall that somewhere you can stop the requirement to return to the welcome screen on resume (but maybe that was only with the screen saver). There's definitely no disk activity when it freezes (I have not tried just leaving it for a while and seeing if it resurrects). – Lawrence Dol Feb 13 '10 at 2:17
  • Take a look in Control Panel > Power options, should all be there – William Hilsum Feb 13 '10 at 2:44
  • Thanks for the idea, but this wasn't it. In my case the UI becomes unresponsive, except for the mouse, a minute or so upon resuming; then a few seconds later the mouse stops responding too, and we are out to lunch; time to press reset. – Lawrence Dol Feb 14 '10 at 5:55
  • 1
    Note to others: This does not address my problem - the bounty is still very much up for grabs. – Lawrence Dol Mar 23 '10 at 21:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.