0

I'm trying to set up a SSH connection between my personal pc from home and my laptop which will be on a different network. I've read a bit about SSH connections and I saw that I had to open port 22 on my pc. I entered the router settings (I have an edimax BR-6428nS) and on the port forwarding I entered the details to open the port. Next, on my pc I installed Bitvise SSH Server and I started the server. On my laptop, I installed Putty in order to connect to my pc. Now comes the problem, from my local network, when I'm at home the connection works and I am able to connect to my pc but I'm on the same network. I tried to connect from a different network and I just get connection timed out on putty...Can you guys help? Thanks!

Router Settings:

Router Settings

Server Settings:

Server Settings

0

You're connecting to the public ip address of your router and not 192.168.2.101 when at the remote location, right?

Try these:

  1. First test connecting when on same network, but do not connect to local ip address of the PC - use public ip address of the router instead.

  2. If above works and you still cannot connect to the PC from different network then try pinging your router - to verify it is possible connect to it.

  3. Finally, your service provider (either at home or at the remote location) might be blocking port 22 TCP traffic. Switch configuration of Bitvise SSH and on your router to port 80 or 443 and test if it works now.

Also consider to set up static ip address for your home PC - don't use DHCP lease (automatic ip address) because your setup could easily break if the PC decides to get different than 192.168.2.101.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.