0

I can see that I have a new update on my machine 'Upgrade to Windows 10 Enterprise, version 1511, 10586'. The Windows update is constantly nagging me to restart my computer but when I do restart (I select 'Update and restart' nothing happens, the machine just restarts normally. When I go to the knowledge base link for the update (https://support.microsoft.com/en-us/kb/3012973) I get 404.

I've tried running:

  • sfc /scannow
  • DISM.exe /Online /Cleanup-image /Restorehealth
  • MediaCreationTool.exe

SFC and DISM reported no errors and everything looks to be ok. On MediaCreationTool.exe I selected the Upgrade but it claims that my windows version is not supported by that tool. Winver states that I'm on Windows 10 Enterprise (Build 10240).

Does anyone have any idea how I could apply the update?

Edit:
There is already a similar question asked (My Windows 10 Enterprise still has not got the November update (1511)) but it is not the same case as I have.
Unlike the other question the update is in my windows update list. My computer is constantly nagging me to reboot to install the update.
Additionally I have another computer (laptop) which also has Windows 10 Enterprise edition. I've installed both computers at the same time a year ago. This other computer is already updated to 1511 (Winver states: Microsoft Windows Version 1511 (OS Build 10586.318).
On this other computer I can see that the update was installed (see third item in the windows update history)

Windows update from my laptop which was already updated

Just to be complete here is the windows update history from my computer which doesn't want to install the update:

Windows update on my computer which does not want to install the update

  • I'd recommend that you go to update "history" (advanced options->view update history) to see what the error is. Then post that error number here for us to see – egray May 29 '16 at 14:45
  • @DavidPostill I've edited my answer to state why my question is not the same – Dalibor Čarapić May 30 '16 at 6:36
  • @egray There are no errors in the update history. Here is the screenshot: imgur.com/ZsLkj39 – Dalibor Čarapić May 30 '16 at 6:42
  • I have exactly the same problem, but with Windows 10 Home. What is strange is that this update appeared after restarting windows in order to install regular updates (The KBs you can see in the screenshot above). This Windows Update, however, was not listed before the restart. Also the update seems to be an old one (Nov 2015). – Olivier Jacot-Descombes Jun 3 '16 at 18:20
0

Did you try restarting with the restart button on the update page in the settings app? That worked for me for Win 10 Pro.

  • I've just tried it and there was no effect. – Dalibor Čarapić May 30 '16 at 6:42
0

I could solve the problem by clearing the Windows Update history. You can download a tool doing this from this Microsoft web page: Reset Windows updates.

The tool is a BAT file that you have to run with administrator privileges.

In my case, running services that could not be stopped, made the process fail. Therefore I had to restart windows in safe mode before running the batch file.


Note: Clearing the update history does not remove the updates themselves, it just clears the update log.


A side note: This is a big update, which restarts Windows several times and can take hours to perform, depending on your hardware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.