1

I am running an ubuntu server in my LAN. Streaming videos and music was done with mediatomb but it looks like the server denied sending UHD videos. I also tried MiniDLNA but ended up with the same problem.

As testing devices I used an LG 55UF6809 and an older Panasonic TV, which has no UHD capabilities but was still unable to play the video. That made me think the issue is probably with the Server and not with the TVs. UHD content from Netflix plays fine.

The server is an HP ProLiant MicroServer Gen7. The network is definitely fast enough to stream content. The files are stored on a WD Red, if that matters. Playing the files on a PC over Samba or NFS share works well too.

Any ideas on how to stream UHD videos within my network?

0

Plex is a media streaming application with a free media server that can function as a DLNA server and supports 4k. It runs on Linux (as well as Windows, OSX, and NAS devices).

Here's a guide for setting up DLNA with Plex.

| improve this answer | |
  • Plex has really high cpu and memory usage. I tried it before but it ran really slow. Are the mediatomb and minidlna both unable do stream 4k? I would like to stick with a lightweight server because I don't need all of the functionality of Plex. Obviously if there is no other option I'll try this again :) – byf-ferdy May 30 '16 at 8:32
  • Unfortunately I don't know the other two you mention so I can only expand a bit on Plex. How did it run really slow? Was it through DLNA? I totally understand you want something lightweight, but for me personally the ease of using/installing Plex was just more important. – Mikael Kjær May 30 '16 at 8:38
  • The server was running on 60% CPU on idle. Streaming files was lagging. I am pretty sure it was because of transcoding. Is it possible to disable transcoding in Plex? I'll give it another go tonight and let you know – byf-ferdy May 30 '16 at 11:11
  • Yes, you can enable direct play, but I'm not sure if it works with DLNA as I've never tried that. – Mikael Kjær May 30 '16 at 11:37
  • As it tourns out the plex dlna does not stream 4k videos in this case either. Neither is the plex app for my Smart TV – byf-ferdy Jun 2 '16 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.