2

I am getting the error: "Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Could not connect: Connection refused" when I try to run gnome-terminal. I am running CentOS 7. I am using SSH to remotely connect to the VM and am using VcXsrv to get the GUI.

When I try to run terminator, I get a similar error: "Failed to connect to socket /tmp/dbus-8LlMXZC0jW: Connection refused"

I think this is related to a permissions issue as gnome-terminal runs fine when I run it as sudo. It was also working fine some time ago so I believe I messed up some file permissions somewhere.

0

This problem occurred to me when I connected to the same X Server from two different X clients simultaneously. Both were connected through SSH with forwarding and they used the same screen number. Closing one of the SSH connections fixed it.

The second error Failed to connect to socket is another issue. It does not prevent the terminal from running.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.