I had installed NVIDIA drivers along with nvidia prime on Ubuntu 12.04, to run CUDA-based applications in a first time. Then, I created a mess on the system because I installed Bumblebee as well, but I was not aware about the incompatibility issues between Bumblebee and nvidia prime. As a result, nothing more worked. Now I would like to recover the previous configuration.

However, if I type on terminal lspci | grep -i vga the only output item is

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

that is the inner intel chipset of my laptop. As you see, the NVIDIA graphic card does not appear (of course it did when everything worked). I also tried to install the nvidia-340 driver, but after the reboot the system does not detect the card yet.

In addition, but I don't know if it is correlated, I'm not able to install nvidia-prime anymore. When I try to do that, the output is:

Package nvidia-prime is not available, but is referred to by another package. 
This may mean that the package is missing, has been obsoleted, or is only available 
from another source

E: Package nvidia-prime has no installation candidate

Does anyone knows where the issue lies? Thanks in advance



lspci -nn | grep '\[03'

Reason is that for some video cards, they're not listed as a

  • [0300] VGA compatible controller

they could be:

  • [0380] Display controller
  • [0302] 3D controller
  • 1
    still not showing for me, after reading all entries of lspci -nn no signs of it. Also can't find any settings in BIOS related to a second video card. I have a Precision 5520 with official ubuntu support, and although the "build your config" page clearly showed it comes with a NVidia card I'm beggining to doubt it has one. – Fabio Jun 30 '18 at 4:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.