19

For some reason, my PERSONAL.xlsb file is no longer opening automatically.

I've checked the Trust Center and the file location (C:\Users[user]\AppData\Roaming\Microsoft\Excel\XLSTART) is a Trusted Location. I have also checked that the file is not a Disabled Add-in.

What am I missing here? I can manually open the .xlsb every time I open excel and run the scripts via the visual basic editor, but the quickaccess buttons no longer work.

How can I get PERSONAL.xlsb to open automatically again?

5 Answers 5

23

Sometimes a Personal workbook gets disabled.

Try this in Office 2016;

File>> Options>> Add-ins

Go to manage (bottom of box) and choose Disabled Items

If your personal.xlsb file is in the list, select it and click on the enable button

Restart Excel

4
  • Holy smokes, Batman. I could kiss you. Feb 10, 2017 at 20:44
  • 1
    You are welcome. But if that doesn't work, you may have to rename you personal.xlsb file and create a new one, then copy your macros to the newly created personal workbook.
    – mooseman
    Feb 13, 2017 at 16:33
  • This solved the issue for me, too. Pretty well-hidden, this setting. Would not have found it in hours. Jun 15, 2018 at 16:20
  • BTW you need to actually go to the "Manage" section and select "Disabled Items", GO, even if the personal.xlsb does not show in the listbox above that button.
    – Leo
    Mar 24, 2021 at 1:10
9

I had the same situation as OP in that I could not externally launch macros in my personal.xlsb file, but could open the file manually and run the macros without any issue. My Tusted Location setting were also unchanged and still in order.

What happened: My personal.xlsb file became unloaded while working (not sure how). All my Addon & Trust settings were correct. Closing and re-opening Excel would not reload my personal.xlsb file. I realized after opening and closing Excel several times that the Task was not ending and I was stuck in the same instance of Excel.

The solution: Ended EXCEL.EXE from the Task Manager, opened a new workbook and my personal.xlsb file launched normally.

1

I tried restarting excel a few times with no luck. For me, I had to close every office app, then restart excel for personal.xlsb to once again open on excel startup.

1
  • So, are you saying that closing every Office app and then restarting Excel reliably solves the problem?  Have you tested it “a few times”? Apr 11, 2018 at 21:02
0

I had to recreate a personal.xlsb and copy all of the (89) macros back to it. It worked fine on Excel 2013, but the same file with the same macros would not load automatically in Excel 2016 though I could manually open it without any problem. Once I recreated it, it auto loaded when Excel started as it should have.

0

Goto C:\Users\Name\AppData\Roaming\Microsoft\Excel\XLSTART and find Personal.xls or Personal.xlsb. Right click it and select "Properties". Make sure the Hideedn box ix not checked. It worked for me. Good luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.