0

I am trying to watch a video on Google Chrome and I got this error below. Could anyone tell me how to solve this problem? I can view videos normally on Youtube but with this page I have the problem. Thank you.

[Error screenshot: black screen with "Couldn't load plugin" text centered, on a gray background

  • 1
    What device are you attempting to view the video on? The device may not support the plugin. – Jerard Puckett Jun 2 '16 at 13:03
  • 2
    What plugin is it trying to load? – TheKB Jun 2 '16 at 13:09
  • Thank you. I am browsing it on laptop. For the plugin I don't know what it is. How can I check that? – Nguyen Van Huan Jun 2 '16 at 13:23
  • 1
    Try going to here and seeing what it says. – TheKB Jun 2 '16 at 13:34
  • Hi, the exact same problem happened with the link you gave. – Nguyen Van Huan Jun 2 '16 at 13:35
1

It appears that the plugin that is not working is flash.

  1. Go to chrome://plugins
  2. Click Details
  3. Find Adobe Flash Player
  4. Under Type: PPAPI click Enable

If that doesn't work, update Chrome.
Source

  • 1
    @NguyenVanHuan Try IE or Firefox then. It really should work. It works for me in FF and Edge. – TheKB Jun 2 '16 at 13:59
  • 1
    Are you using anything that would prevent plugins (VPN, overzealous web filter, etc.)? – TheKB Jun 2 '16 at 14:08
  • 1
    I can't check that because I don't have your software installed. Could you try an online proxy such as hide.me? – TheKB Jun 2 '16 at 14:12
  • 1
    Perhaps. I doubt it though. Try it on another computer and see if it works. I can't really help anymore though. – TheKB Jun 2 '16 at 14:33
  • 1
    This is most likely a network problem or filter. To confirm this you could try a free VPN and see if that works. – TheKB Jun 2 '16 at 14:37
1

In versions of Chrome prior to version 57, it was possible to configure Flash via chrome://plugins however this feature has since been removed. For the newest versions of Chrome, if the browser displays the error "Couldn't load plugins" then try the following remedies:

  1. Ensure that Chrome is configured to allow the desired website to run Flash. Unfortunately, Chrome will no longer allow a website to Flash to run by default, or even popup a small dialog to ask permission. Instead, it is necessary to explicitly configure Chrome. To do this, navigate to chrome://settings/content and then either enable Flash for all sites by choosing "Allow sites to run Flash" (which, depending upon how the browser is used, may be a security hazard) or else enable it for only the desired website via "Manage Exceptions..." and then enter the desired site, e.g. mysite.com, and press enter.
  2. If that doesn't work, uninstall Chrome and reinstall. This is tricky because the uninstaller program does not fully uninstall Chrome. Find instructions on the Internet to help with this (it involves deleting directories, modifying the registry, etc.) Also note that, although this step is frequently recommended, in my experience it is a long-shot because it seldom works.
  3. If that doesn't work, then download and install the Pepper Flash Player from Adobe. However, this approach can lead to another issue, which is that Chrome will not run an external Flash Player if its own bundled Flash Player is of a newer version. Since Chrome auto updates itself frequently, and since Adobe releases new Flash Player versions frequently, this may happen before long. To work-around this issue, run Chrome with the --disable-bundled-ppapi-flash command-line switch.

PS, Whatever you do, if you download and install Flash Player then do so only from adobe.com domains. Do not, under any circumstances, respond to popups advertisements from other domains which offer to "fix" or install Flash Player as these may introduce serious security hazards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.