4

I am trying to connect to my linux shared hosting via SSH from my windows 10 laptop. It is not connecting at all. I have tried Putty (both 32 and 64bit), MobaXterm and one other SSH client and I am getting the above error on Putty:

Network Error: Software caused connection abort

and this error on MobaXterm

Server unexpectedly closed network connection

It worked the first few times on Putty then all of a sudden started throwing the above error. My friend can connect to my shared hosting from his machine on a different network, but he does have the same model router as me. I don't even see the prompt to enter login credentials, connection is refused prior to that.

I have talked to my hosting provider and they were able to connect. I have literally spent all day trying to figure this out.

2

All over SO and Superuser I've seen absolutely loads of suggestions and loads of unanswered questions or discussions to do with SSH, but particularly in my case Putty, abandoned abruptly halfway through solving the problem. Normally just when they where about to provide some information that was relevant! So here is a list of as many of the common trouble shooting tactics I could find that will hopefully help you when trouble shooting SSH connection problems with Putty. It's fairly safe to say I've read every post on SO and Superuser about Putty.

  1. set keep alive to 300 (this only helps when you get that error after you're connected, not while connecting)
  2. Try using multiple SSH clients
  3. Make a firewall exception for the SSH client and port 22. Here is a list of public SSH servers: shells.red-pill.eu Try on to check post 22 isn't blocked
  4. run netsh int tcp set global autotuninglevel=disabled
  5. update reg key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\TcpMaxDataRetransmissions to 16
  6. ping server
  7. rebooting computer (it's good to try the obvious)
  8. restart SSH server
  9. check with your host its not a "Fail2Ban" or some other ban for entering the wrong password 3+ times
  10. If all else fails there should be a hammer in the back room somewhere...
  • No. 9 was my problem – yobddigi Jun 2 '16 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.