0

I have a problem related to Transmission torrent client. Specifically on a Fedora 23 Linux distribution.

My goal is to increase download speed and surfing on the internet. I found out the best way to do it was port forwarding.

I followed online guides and tried to do it manually via the router page, accessed through the IP address. Then I did the same using the firewall GUI app you can download through the software manager. However, doing the test from preferences in Transmission, the result is always "port closed".

The firewall GUI is called Firewall Configuration, which I assume just modifies my personal firewall on my Fedora.

I'm forwarding on port 51413, transmission default port, to the same on the standard IP I got from my router page online. The router is not my Fedora box, but an external TP link modem.

I tried disabling the firewall, specifically FirewallD on Fedora, but nothing changed.

EDIT: SOLVED i finally solved: apparently transmission had a problem with the option "use UPnP or NAT-PMP port forwarding from my router" , which automatically fowarded port 51413 on the router. disabling the option and forwarding manually another port worked.

  • 1
    Can you edit your question to be very clear about which box is which, and what ports and IPs are involved? Is your Fedora 23 Linux box also your router, or is it just the Transmission client box sitting behind some other, as-yet-unspecified router? What ports did you forward and to what IP:Port pairs did you forward them to? What is this "firewall gui app you can download through the software manager" — Is it safe to assume it's something that adjusts the "personal firewall"/"software firewall" running on the Fedora host? Did you try turning off the Fedora box's local firewall all together? – Spiff Jun 3 '16 at 19:53
  • 1
    You appear to have created 2 accounts (this one and superuser.com/users/601286/tidus). See How can one link/merge/combine/associate two accounts/users? and/or I accidentally created two accounts; how do I merge them? for guidance on how to merge your accounts. That will allow you to edit and comment on your own question. – DavidPostill Jun 3 '16 at 21:09
  • "forwarding port 51413" or "forwarding on port 51413"? – Scott Jun 4 '16 at 1:48
  • i finally solved: apparently transmission had a problem with the option "use UPnP or NAT-PMP port forwarding from my router" , which automatically fowarded port 51413 on the router. disabling the option and forwarding manually another port worked. – tidus Jun 5 '16 at 19:14
0

You need to work at two levels, computer and modem router:

  1. Open Transmission and go in Edit -> Preferences -> Network
  2. Copy the port number (eg. 51414)
  3. Check "Use UPnP or NAT-PMP port forwarding from my router" enter image description here
  4. Open a terminal and, as root, give the following command to open the port in the firewall permanently:

$ sudo firewall-cmd --permanent --add-port=51414/tcp

For a temporary solution, instead (after reboot this firewall setting is lost), you can use this other command:

$ sudo iptables -I INPUT -p tcp --dport 51414 -j ACCEPT

  1. Now the last step, that is the manual configuration of your modem router, by opening a web browser at your IP address (check the previous guide to find out it: it could be 192.168.1.100, or 192.168.1.1, or 192.168.178.1, or something else)
  2. For FRITZ!Box 7490 modem router, for example, you need to go in Internet -> Permit Access => select a device => now click on New Sharing or, if you have olready one, click on the edit icon to add a new forwarding => New permit access -> as application choose other application to enter a custom name -> as protocol choose TCP -> then as port 51414 in all the three fields => OK => OK => Apply
  3. Now test Transmission, going in Edit -> Preferences -> Network -> Check port => OPEN!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.