5

How is it done to turn off screen blanking in Weston with wayland backend not X. I have tried:

setterm -blank 0
setterm -powersave off
setterm -powerdown 0
echo -ne "\033[9;0]" >> /etc/issue
echo 0 > /sys/class/graphics/fb0/blank

As well in weston.ini i set the screensaver duration to 0. But that section is confusing because it says to uncomment path to disable screensaver. But after 10 minutes the screen still turns off.

This distro was built with yocto core-image-weston.

1

Try adding idle-time=0 under [core], in weston.ini.

Source

1

From man pages for weston.ini, to disable screen locking, add next lines:

[core]
idle-time=0

[shell]
locking=false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.