0

I am trying to install the standalone Visual Studio Emulator for Android on Windows 10 Pro. According to the page, Visual Studio 2015 is not required and I've had the emulator installed on running on this machine previously under Windows 8.1.

Before the emulator, I installed Visual Studio 2013 Professional, SQL Server 2016 Developer Edition and the June 2016 SSMS package, and SQL Server Developer Tools, as well as Android Studio. Some of the SQL Server tools installed the Visual Studio 2015 Isolated and Integrated shells, so I don't know if that's confusing the installer into trying to install the Visual Studio extension into a non-supported version. Uninstalling/removing the SQL tools is not a simple process as it completely litters the program list with dozens of items.

The installer says "Microsoft Visual Studio Emulator for Android (Visual Studio Extension) Fatal error during installation." and the log file contains these lines:

[129C:155C][2016-06-04T18:25:27]i323: Registering package dependency provider: {0B8032D4-EB09-4FE2-8A6F-8F709BE0B6BB}, version: 1.0.60106.1, package: emulator.vsix.msi
[0738:058C][2016-06-04T18:25:27]i000: MUX:  ExecutePackageBegin PackageId: emulator.vsix.msi
[129C:155C][2016-06-04T18:25:27]i301: Applying execute package: emulator.vsix.msi, action: Install, path: C:\ProgramData\Package Cache\{0B8032D4-EB09-4FE2-8A6F-8F709BE0B6BB}v1.0.60106.1\packages\emulator.vsix\emulator.vsix.msi, arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7"'
[0738:058C][2016-06-04T18:25:27]i000: MUX:  ExecuteError: Package (emulator.vsix.msi) failed: Error Message Id: 0 ErrorMessage: Microsoft Visual Studio is required, but is not installed on this computer. Please install it and try again.
[129C:155C][2016-06-04T18:25:27]e000: Error 0x80070643: Failed to install MSI package.
[129C:155C][2016-06-04T18:25:27]e000: Error 0x80070643: Failed to execute MSI package.
[0738:058C][2016-06-04T18:25:27]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[0738:058C][2016-06-04T18:25:27]i000: MUX:  Installation size in bytes for package: emulator.vsix.msi MaxAppDrive: 0  MaxSysDrive: 73728  AppDrive: 0  SysDrive: 73728
[0738:058C][2016-06-04T18:25:27]i000: MUX:  Return Code:0x80070643 Msi Messages:Microsoft Visual Studio is required, but is not installed on this computer. Please install it and try again. Result Detail:0 Restart:None
[0738:058C][2016-06-04T18:25:27]i000: MUX:  Set Result: Return Code=-2147023293 (0x80070643), Error Message=Microsoft Visual Studio is required, but is not installed on this computer. Please install it and try again., Result Detail=, Vital=True, Package Action=Install, Package Id=emulator.vsix.msi
[0738:058C][2016-06-04T18:25:27]i000: Setting string variable 'BundleResult' to value '1603'
[0738:058C][2016-06-04T18:25:27]i319: Applied execute package: emulator.vsix.msi, result: 0x80070643, restart: None
[0738:058C][2016-06-04T18:25:27]e000: Error 0x80070643: Failed to execute MSI package.
[0738:058C][2016-06-04T18:25:27]i000: MUX:  ExecutePackageBegin PackageId: emulator.vsix.msi
[129C:155C][2016-06-04T18:25:27]i318: Skipped rollback of package: emulator.vsix.msi, action: Uninstall, already: Absent
[0738:058C][2016-06-04T18:25:27]i000: MUX:  Installation size in bytes for package: emulator.vsix.msi MaxAppDrive: 0  MaxSysDrive: 0  AppDrive: 0  SysDrive: 0
[0738:058C][2016-06-04T18:25:27]i000: MUX:  Return Code:0x0 Msi Messages:Microsoft Visual Studio is required, but is not installed on this computer. Please install it and try again. Result Detail:0 Restart:None
[0738:058C][2016-06-04T18:25:27]i000: MUX:  Reset execution Result
[0738:058C][2016-06-04T18:25:27]i000: MUX:  Reset Result
[0738:058C][2016-06-04T18:25:27]i000: Setting string variable 'BundleResult' to value '1603'
[0738:058C][2016-06-04T18:25:27]i319: Applied rollback package: emulator.vsix.msi, result: 0x0, restart: None
[129C:155C][2016-06-04T18:25:27]i329: Removed package dependency provider: {0B8032D4-EB09-4FE2-8A6F-8F709BE0B6BB}, package: emulator.vsix.msi
[129C:155C][2016-06-04T18:25:27]i351: Removing cached package: emulator.vsix.msi, from path: C:\ProgramData\Package Cache\{0B8032D4-EB09-4FE2-8A6F-8F709BE0B6BB}v1.0.60106.1\

Since it should be possible to use the emulator without Visual Studio, I don't know why it aborts the entire installation when it can't install the extension, or how to get it to continue without it.

I don't want to have to install the entire Visual Studio 2015 product because I don't qualify for the Commmunity edition and I'm already using Visual Studio 2013.

  • Try installing the community edition, I bet it works, or uninstall the components that installed the VS2015 command shells. Error is clear, in the past you did have it, you just had VS2013..... – Ramhound Jun 4 '16 at 23:59
  • I uninstalled what I believe to be the components that installed the VS shells, but of course they aren't automatically uninstalled also. I manually uninstalled the shells and was able to get the emulator to install. Now I'm trying to reinstall the other components. Hopefully I didn't break anything, but I think Microsoft should fix this. I'll have to find the right channel to report this bug to. – GWB Jun 5 '16 at 0:20
  • Hi, I am having same issue, could you detail your solution in the answer so I could follow yours? Cheers – Darren Christopher May 1 '18 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.