2

connection CONSTANTLY DROPS, and it's not just the internet connection, it's the connection with the router as well because i cannot ping it when it happens. Here are the screenshots, this first one is when i ping it from my Desktop computer:

enter image description here

This second one is when i ping it from my laptop (At the same time as the first screenshot is happening), as you can see the connection doesn't really drop as there's no "Request timed out." but there's this ABSURD response time of up to 3452ms and I'm simply pinging the ROUTER.

enter image description here

I'm using LINKSYS E900. The issue tends to happen when I try to load sites like twitch.tv and the sort.

Any ideas on how to fix it?/Why this is happening?

I was thinking of flashing the router's firmware to dd-wrt but I have absolutely no idea if that'll improve its performance or if it'll just give me more feautures while still malfunctioning.

Both are wireless connections. The signal strength is reasonable and there's little interference (the brown line with the higher strength is my wifi)enter image description here

  • Both wireless connecitons – Jose V Jun 5 '16 at 7:21
  • Do you get the same results running a wired connection? – Raystafarian Jun 5 '16 at 7:26
  • I do not have a wired connection, but i could get a cable in like two days and test it that way, what would it mean whether it works the same on cable or not? – Jose V Jun 5 '16 at 7:41
  • Whether the wireless is going out (or being interfered with) or the router is completely unavailable. I wouldn't worry about doing all that. What if you reflash the router to default? Or update the firmware? Does that change the behavior? What if there's a different router, does it also happen (interference)? – Raystafarian Jun 5 '16 at 7:45
  • I will try updating the firmware/flashing it to dd-wrt maybe even, but I'll need a cable for that so I won't be able to show results for now. That's why in my post I said I was thinking of flashing the router's firmware to dd-wrt but I have absolutely no idea if that'll improve its performance or if it'll just give me more feautures while still malfunctioning. so now I'll just wait and hope. – Jose V Jun 5 '16 at 12:11
0

This problem happens due to your wireless key version and encryption type incompatible with your system. I've also faces such a problems in my TP-link router. TO fix the problem set the version as WPA/PSK and encryption type as AES. And if your router have option to select automatic in both case than choose automatic or default settings.

| improve this answer | |
  • I'm not sure what you are talking about, the "security mode" in my router is already set to WPA2/WPA mixed mode, the only options on it are WPA 2, WPA and WEP, there's no option to set the "encryption type". Tell me if I'm totally lost. – Jose V Jun 5 '16 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.