3

I am able to RDP to an admin account but not a non-admin account to my win 10 machine as host

Here is an equivalent question relating to what I want to do however for win 7: Allow Non-Administrator Users to Access Windows 7 Home Premium Via Remote Desktop unfortunately this is different in win 10 and I haven't been able to directly translate.

I have tried adding the user in the group policy editor to:

Local Computer Policy → Computer Configuration → Windows Settings → Security Settings → Local Policies → User Rights Assignment → "Allow log on through Remote Desktop Services" but unfortunately that hasn't made any difference.

Thanks to anyone who can help

  • Professional or home premium. – Zalmy Jun 6 '16 at 20:46
-2

You can follow the answer https://superuser.com/a/719819/750636, it works also for Windows 10 (I have Win 10 Home).

It's basically about adding a builtin group Remote Desktop Users (which is different from if you add group manually with net localgroup add command, even if it has same name). Then you can add your common non-admin users to that group using net localgroup command.

Also don't forget, that you need temporarily to elevate your permissions to merge new values into registry. You can do it in regedit on key HKEY_LOCAL_MACHINE\SAM\SAM (right-click on key node -> Permissions -> select Administrators -> check Full Control -> OK). After merging the .reg file into registry, you better remove Full Control permissions of Adminitrators group from that key node.

Also there is a good guide summary on RdpWrap github. They use PsExec to start regedit as System user, which is also good, because you don't need change any permission in regedit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.