0

I really need help from someone who has more knowledge about WD external hard disks. The story goes like this:

Everything was fine until 2 days ago when my WD Passport Ultra 1TB suddenly refused to accept the password, which I've always entered whenever I want to unlock it. It keeps on saying 'invalid', and sometimes the unlocker becomes slow or hangs (or the font becames blurry).

I'm 100% sure the password is correct because I'm using the same password when I login to Windows 7 on my laptop. This happened once before but the problem appeared to have cleared up afterward. It's been 2 days since I was last able to access to my hard disk. I don't want to wipe the data or format the hard disk, since I have many important documents and pictures I want to keep, especially the pictures and videos of me and my late friend.

  • It sounds to me the disk or hardware encryption mechanism may be failing as you say it's happened before and "fixed itself"... Additionally, with all encryption (and is the sole reason to encrypt - to prevent unauthorised access of data) if a user doesn't know the password or the underlying decryption system has faults then the data will not be recoverable, unless you're prepared to pay lots of money for forensic specialists to TRY to get round the encryption. In a nutshell: if you don't have a backup of your data and you can't recover the encrypted data = you've lost the lot. – Kinnectus Jul 7 '16 at 7:18
1

Western Digital has very much dropped the ball in regards to providing data storage solutions the past few years.

Can you get on linux? Even with a LiveCD/LiveUSB? If you can, then I bet the slow fix will do you good.

WD have neutered their drives to 'proactively' mark perfectly good sectors for relocation when they don't actually need it. This slows down each and every sector operation on disk, including checking KEKs due to the wonky way they've made their firmware.

This worked for my 2TB model:

Step 1) Make sure the drive can be seen on the bus:

sudo lshw -businfo

Step 2) Get yourself hddsupertool (Unless you follow the manual method linked later) here.

Run as root, select the device, and select the VSC entry.

Step 3) Select this entry:

4) WD royl (Marvel) patch mod 02 (slow fix)

Step 4) You want to first

1) Read the module to a file and create the patch.

followed by

2) Write the patched data back to the disk.

Step 5) Go back to VSC entry, select:

5) WD royl (Marvel) patch mod 32 (slow fix)

and perform entries 1 & 2 again (reading mod, patching, and writing back)

Note: It may tell you it's failed on the final step. It still worked for me.

Step 6) Power cycle the drive

What you've just done: You've cleared the SMART status, and the file relocation list. The re-lo list contains info about which sectors need to be relocated, which in WD's case happens quite nearly every time on a failed read. This means the tiniest vibration, a slight cord stretch, or fairies bangin' on the platters.

Credit: Spildit (Manual Method of doing this) & Scott Dwyer (Author of hddsupertool)

I personally went from 130KB/s scan i/o speed in testdisk to 11-13MB/s after the fix, and I was able to recover data at +100MB/s from as far back as the very first time I used my similar drive. After this fix, I'm using this drive TODAY with zero issues. WD is not the company they used to be.

It really grinds my gears seeing people just agree with the status quo on electronics hardware - especially hard drives - along the lines of "it's bad, replace it." Looking a little deeper, most of my hard drives have not only been rescued thanks to 'seemingly arcane' methods, but most are actually still in service today!

(If you need help getting on linux, let me know, I'll gladly get on a chat of some form and help you through this, I have a displeasure for WD right now burning with the fury of a thousand misaligned heads.)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.