22

A similar question was asked 4 years ago, when Firefox 13 introduced lazy loading: How do I make Firefox 13 Load All My Tabs on Startup or when Resuming Reload

Firefox 13 (Released June 5, 2012) has introduced a new default setting to Load Tabs on Demand. This causes the browser to only restore the currently selected tab when resuming a session on startup, after a crash, or on a requested reload. I really don't like how I now have to click each tab and select restore. How can I turn this off?

My problem is, the solution found there (going to options => "General", or later "Tabs", and then unchecking "Don’t load tabs until selected") doesn't work anymore: since the new version 47, that option seems to have been removed.

Is there a new way to force Firefox to load all tabs when resuming a session?

35

I wanted the same and I found the answer here >> https://support.mozilla.org/en-US/kb/allow-firefox-load-multiple-tabs-background:

This applies to versions 47 and up.

When you restart Firefox and restore your previous session, Firefox will wait until you select a tab before loading it. This keeps Firefox running quickly and smoothly.

If you've allowed an earlier version of Firefox to simultaneously load multiple tabs in the background (offered as the "Don’t load tabs until selected" check box in the Preferences menu), when you upgrade to version 47 and up, your setting will reset to allow only one tab at a time.

You can change it back through your about:config preferences (advanced users only):

  1. In the address bar, type about:config and press Enter.

    The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page.

  2. Search for browser.sessionstore.restore_on_demand.
  3. Change the value to false.
  4. Close the about:config tab to save your changes.

Allowing Firefox to load tabs simultaneously can slow down its startup.

6
  • 4
    Half of the settings and add-ons I have installed in Firefox are to fix features they intentionally "broke" in subsequent releases. After several decades as a loyal user, I have finally switched to Vivaldi because I wouldn't put up with it any more. I still have Firefox installed for the very rare page that Vivaldi doesn't handle correctly. Usually, it works better than Firefox on rendering pages. – Joe Jun 14 '16 at 17:28
  • Ditto, although Vivaldi went the same path for tabs lazy loading: at first it wasn't available, now it's enforced :( – user14764 Jun 15 '16 at 8:48
  • It is not a clear solution. After enabling it, FF didn't asked to restore and the second window (from restoring manually) didn't load in background all the tabs. – Waldemar Wosiński Jan 6 '17 at 7:33
  • Thank you! When I have to restart FF I'd like all my open tags (only 3-4) to load up. – Bulrush Sep 30 '17 at 11:10
  • still working for firefox 60.2 – Jovasa Jun 8 '18 at 17:23
0

For those who don't want to load all the tabs on startup, my solution was to pin the few tabs that I want always available and keep the rest lazy-loaded by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.