0

I'm trying to set the compatibility of some programs in Windows 7 so that they always run as administrator, no matter who is logged in.

I've tried setting this via the "Compatibility" tab of the programs' properties. More specifically, I have clicked the "Change settings for all users" button and then checked the "Run this program as an administrator" box.

The problem is that whatever changes I make never get reflected in the first dialog window after I click "Okay" in the second. The box always remains unchecked. I can never tell if the setting has been enabled or not.

Why does it do this? Is there something I can do to get it to work? Thanks.

Windows 7 x64 SP1

  • You can't do that. It would be a big security hole. – DavidPostill Jun 7 '16 at 21:38
  • A few video games are a big deal? Then why show the setting in the first place? – posfan12 Jun 8 '16 at 3:16
0

Only non-system applications and processes can be selected to always run with administrator privileges. Applications marked to run as administrator will not launch properly when initiated from standard accounts. Any changes you make in contradiction to this will not be accepted by the system, and this is probably why the box remains unchecked.

You can read the article below to see what is possible, but you will have to accept that some applications will never run automatically with admin privileges in Genuine Windows 7.

https://technet.microsoft.com/en-us/magazine/ff431742.aspx

| improve this answer | |
  • They're just some video games. And the setting does work. It's just not shown properly in the dialog. – posfan12 Jun 8 '16 at 3:17
  • Ok, well games are certainly non-system applications so no problems there. You should however still be prompted to allow the application if it is making changes that require administrator privileges. Out of interest, why do the games need to be run as administrator? Do they not run otherwise? – Matthew Jun 8 '16 at 10:39
  • I do get prompted. However, the dialog doesn't reflect this. – posfan12 Jun 12 '16 at 22:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.