2

New Dell XPS 13 touch notebook computer has developed a sleep issue - it refuses to sleep, waking up instantly after putting the computer in sleep mode either via the start menu or via closing the lid. However, I cannot figure out what is waking it up.

Output of powercfg -lastwake:

Wake History Count - 1
Wake History [0]
  Wake Source Count - 0

Output of powercfg -devicequery wake_armed

NONE

Output of powercfg -waketimers

There are no active wake timers in the system

System logs also indicate that the wake source is unknown.

Hybrid sleep is disabled. Wake timers are disabled. Computer has no external wired devices connected of any kind (no external mouse, etc.). Wi-fi card wake is disabled, wi-fi card wake on magic packet and wake on pattern are also disabled in advanced settings. Teamviewer is not installed.

Any ideas on what might be going on here?

Edit: Apparently regular shutdown is also affected - it boots up again a few seconds after shutting down.

Edit again: And apparently it is working again, after changing literally nothing. What was a completely repeatable issue seems to have spontaneously corrected itself. I wonder if this could be a hardware issue that will occasionally rear its head until the motherboard is replaced. Is there anyone out there seeing a similar issue?

  • Are there any scheduled tasks set in Task Scheduler? – NetworkKingPin Jun 8 '16 at 7:19
  • 69 active, but none have run within the past 24 hours. – alex.forencich Jun 8 '16 at 7:26
  • Also, it doesn't appear to want to shut down either....? It also boots up immediately (well, a couple of seconds) after being shut down. – alex.forencich Jun 8 '16 at 7:26
  • Check out the answer below for you wake timer issue. And if that fixes it. And the shutdown issue remains make a new post stating the shutdown issue. Otherwise add that in to your question. – NetworkKingPin Jun 8 '16 at 7:28
  • And it seems to have spontaneously fixed itself? I literally did not change a single setting and it appears to be sleeping and shutting down properly now. What the heck? Could this be a hardware problem? – alex.forencich Jun 8 '16 at 7:41
0
  1. Go to "Control Panel --> Hardware and Sound --> Power Options --> Edit Plan Settings"

Click "Change advanced power settings"

Go to "Sleep --> Allow wake timers" and change the setting to 'Disable'. Make sure to alter the setting for both 'on battery' and 'plugged in'.

  1. Search: Local Group Policy Editor (or gpedit.msc) Go to: Computer Configuration --> Administrative Templates --> Windows Components --> Windows Update

Double click "Enabling Windows Update Power Management to automatically wake up the system to install scheduled updates" and set it to 'Disabled'.

  • That was one of the first things that I tried. – alex.forencich Jun 8 '16 at 7:27
  • Recheck, I was adding 2. If 2. does not work either, you should create a PwSh script to deny that behavior. – Overmind Jun 8 '16 at 7:30
  • gpedit.msc does not appear to exist – alex.forencich Jun 8 '16 at 7:33
  • It cannot not exist. Run that directly from start and it will launch. – Overmind Jun 8 '16 at 7:34
  • Run can't find it, can't start it from the command prompt, 'local group policy' has no hits, 'group policy' has no hits....has this been removed from windows 10? – alex.forencich Jun 8 '16 at 7:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.