10

I have an internal hard drive that I use as storage where I dump the stuff I need backed up. I want to format it to exFAT instead of NTFS so that it doesn't have to deal with permissions. The problem is, it only appears to be available to format as NTFS. Is there a way to force it to be formatted as exFAT?

16
  1. By Command prompt Format D: /A:64K /FS:ExFAT

64k is cluster size, D is target drive letter.

  1. By Diskpart:

    list disk

select disk '#' (where # is the number of the targer drive)

If you want that for a partition:

list part
select part # (where # is the number of the partition)
format fs=exfat -q 

If you want it for the whole drive just erase it all and make a single partition

clean
create partition primary

active (you many not need to make it active, so you can skip this)

format fs=exfat -q

Update: for Windows 10, use QUICK instead of -q
4
  • beaten by 11 seconds ... and more options to do the same thing too.. – Darius Jun 8 '16 at 8:36
  • Diskpart is good in case there are problems with normal format, but those usually appear for memory sticks, not HDDs. Good to have it, just in case. – Overmind Jun 8 '16 at 8:39
  • 1
    In Windows 10 -q doesn't work anymore, use QUICK instead. – spackmat Jul 21 '17 at 12:24
  • Confirmed, updated. – Overmind Dec 4 '17 at 6:39
4

Open command line (CMD) and run the command below:

format X: /FS:exFAT

It basically means format the "X" Drive with exFAT Filesystem. Change the X to whatever drive letter the internal hard drive has at the moment.

There are other filesystem type, which you can check by doing format /?

1

If windows fails to format your hard drive to exFAT, you can use third-party tools to do the formatting thing for you. For example, PartitionGuru can format hard drive to exFAT as well.

Step 1: Install and run this partition manager and you can see the hard drive in the software.

Step 2: Select the hard drive you want to format and click the Format button on the tool bar.

Step 3: Select exFAT in the file system colume and then click "Format" button.

3
  • That's weird. I used Partition Magic, and no "ExFAT" option neither. – Quidam Jan 31 '20 at 17:53
  • PartitionGuru is now "DiskGenius". – Quidam Jan 31 '20 at 17:54
  • I reformatted a 64GB microSD card using MiniTool Partition Wizard. It showed exFAT before and after. Still unrecognized by Win10 20H2 File Explorer. A Linux VM on Win10 couldn't see it, but a native (live) Ubuntu system did. – Ray Woodcock Apr 7 at 16:16
1

Well it appears that Windows 10 support for exFAT has been dropped in a recent update. The option no longer appears in the drive format dialog, nor does it appear in the diskpart utility. Any mention of exFAT has been expunged from the official diskpart documentation making me believe that Microsoft has officially terminated support for it, even so I cannot find any official announcements or confirmations of that. A very odd and stupid move IMO.

3
  • Someone could explain me why? – Quidam Jan 31 '20 at 17:54
  • This is not the case at all. It certainly still exists in 1909. – Bob Mar 29 '20 at 7:59
  • 1
    It may not appear in some format dialogs as the filesystem type can be encoded in the partition table, so an existing NTFS partition will not allow you to format as non-NTFS through the basic format dialog. If you go through Disk Management and delete the volume / recreate it you will be presented with FAT options depending on the size of the volume - exFAT above 32 GB, FAT32 below. – Bob Mar 29 '20 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.