0

as I have hinted in the question, I have trouble reaching 1Gb/s speeds in my network. All used cables are CAT6 and all network switches are unmanaged 1Gbit switches.

Using FreeNAS on my server, I am only getting speeds of 11.4MB/s, which to me indicates a close to 100Mb/s limit?

Because my NAS gets assigned an IP (DHCP) from the router, is incoming traffic going via the router? See the diagram for my setup below:

Network diagram

I would like to reach transfer speeds of close to 1Gbit/s when working between my computer and my server. Is the slow router speed an issue when hooked up to the switch? Right now, I simply don't know the logical route any transferred packets would take from my PC to the server?

Thank you!

4
  • your network interfaces on the NAS and computer must also be gigabit. In addition, the disc throughput and any virus scanning will be limiting factors. Have you tested the max transfer speed on the freenas box itself to get a sense of the maximum read speed of the storage attached to it? Also: "no," the router acting as a DHCP server does not mean that all LAN-only-traffic must pass through it. – Yorik Jun 8 '16 at 14:59
  • If you want to see how the traffic is getting to the NAS from your PC use the tracert command, tracert "replace with NAS name" or refer to this mediatemple.net/community/products/dv/204643870/… – RyanIG Jun 8 '16 at 15:04
  • @Yorik thank you for your answer. All NICs are 1Gbit interfaces. I have just noticed that the speed via a 500MB/s Wireless router is 11MB/s (which is fine, as the router's ethernet ports are 100Mbit), whereas via a cable connection directly connected to the first switch (connected) to the router is 80MB/s? So I assume the issue actually lies in the connection between the two switches? – Max Jun 8 '16 at 15:08
  • @RyanIG doing tracert "192.168.x.xxx" I only get the direct connection, one line of output and a ping <1ms. I assume that means a direct connection? – Max Jun 8 '16 at 15:10
0

As long as the NAS and your computer are all on the same subnet, you shouldn't ever be touching the router. Is your computer also getting its IP address from the router? According to your diagram, there doesn't appear to be anything on a different network, subnet or VLAN, so I'm assuming there's only the one DHCP server.

You can verify the route your packets are taking by running traceroute (tracert on Windows) from your computer to your NAS. The path that traceroute prints will show you exactly how you're connecting. In your case it should just print your computer name and then the NAS name/IP.

For example, if I traceroute my file server at home from my desktop this is what I get:

robbie@khepri:/home/robbie
$ traceroute thoth
traceroute to thoth (192.168.2.14), 30 hops max, 60 byte packets
 1  thoth.reeds.local (192.168.2.14)  0.421 ms  0.417 ms  0.403 ms

Which shows no additional hops even though it passes through a switch. Conversely, if I traceroute to something on my lab subnet from my desktop, you see it pass through my router even though it's physically in the same location:

robbie@khepri:/home/robbie
$ traceroute 172.24.20.21
traceroute to 172.24.20.21 (172.24.20.21), 30 hops max, 60 byte packets
 1  set.reeds.local (192.168.2.1)  1.345 ms  1.313 ms  1.268 ms
 2  172.24.20.21 (172.24.20.21)  1.891 ms  1.536 ms  1.548 ms

If you're seeing your router's IP in there, something about the way your NAS or your computer is setup doesn't make logical sense. There's no reason to be subnetting, or using VLANs on a network as simple as yours, in a home situation.

Are you able to transfer files between two different clients attached to the same switch as your computer at gigabit speeds? What about with two clients plugged into the switch that your NAS is?

You can test your NAS read speeds by doing:

dd if=/some/big/file of=/dev/null 

This takes /some/big/file and reads it from disk and writes it to nowhere. It will give you a basic (but not perfect) idea of your sustained read speeds. In dd, if=... means InputFile, of=... means OutputFile.

You can test your NAS write speeds by doing:

dd if=/dev/zero of=/somewhere/test.file bs=9000K count=1000

This will write a 9GB file filled with zeros, you need to make sure that the file you're writing is larger than your write cache (if you have one on your NAS) because otherwise you'll see something ridiculous like 48GB/sec

5
  • Thanks! I get a sustained read of 484MB/s with 511MB/s write speed. I have also done traceroute (which I had done before) and I get a direct connection to the server. However, I have a different issue now! I am only getting a link speed of 100MB/s when connecting directly to the switch to which my NAS is connected?! What could be the issue here? – Max Jun 8 '16 at 16:43
  • What card are you running? How are you setting your speed/duplex on the card? Have you checked that the cable/port works properly on a different machine that you know gets gigabit? – Robbie Crash Jun 8 '16 at 21:06
  • Hi there. I have been troubleshooting all day long. I have come to one conclusion. We have a pretty interesting setup in our house, and require a very long cable in one spot. I would assume that cat5e (this cable has been there for a while), although supporting 1000BASE-T, will simply not be fast enough to supply 1Gbit/s over a distance of 100m? (especially since it's UTP) – Max Jun 8 '16 at 21:13
  • 100m is the maximum run for 1000Base-T regardless of cable type. So if you're over that, you're absolutely right: you're not going to be able to reliably get Gb speeds. Your cheapest option to rectify this would be a little 4 port Gb switch. – Robbie Crash Jun 9 '16 at 15:40
  • Thanks for your answer. I have rectified the issue. The cable is not 100m long, I have now replaced all 5e cables by 6a S/FTP. It was still not working, so I had the idea to remove all RJ45 plugs and re-crimp them. Turns out I had one cable where, although my cable showed me a link speed of 1Gbit/s, it never went above 13.3MB/s (slightly above 100Mbit/s). The issue is now solved, and I will mark you answer as the accepted answer. Thank you again! – Max Jun 9 '16 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.