16

I have been a Firefox user for more than 10 years; all my passwords are saved by Firefox password manager and protected with a master password. Now I want to move to Google Chrome (ubuntu 16.04), so I removed the master password in Firefox, and imported all data from Firefox into Google Chrome. Everything is OK.

But now under Chrome, if I want to log into any page, I have to wait 15 seconds until Chrome autofills the credential fields. This happens on all sites which have saved passwords, even new passwords saved using Google Chrome!

What's wrong with Chrome? I have no such problem with Firefox on the same computer.

  • You could be a affected by a bug if it doesn't work after creating new profile. Another user has reported similar issue but wierd I have none – pun Jun 21 '16 at 16:31
  • Thakns :) They said Google Chrome for Linux uses gnome-keyring to store passwords, and gnome-keyring is very slow !! They really should develop their own password manager !!! – Sam Jun 21 '16 at 17:54
  • Nahhh they are planning to move passwords to db used by chrome if i read correctly. – pun Jun 21 '16 at 17:56
  • Here is another thread about the same – pun Jun 21 '16 at 17:59
  • Do you have errors in this chrome://sync-internals/ section ? – pun Jun 23 '16 at 15:29
2

My suggestion would be to drop the browser based password manager and go with a 3rd party password manager like Lastpass.

Some options

Personally, I have been using Lastpass for over 6 years, never had an issue, and it works beautifully on Android, Windows, Mac and Linux OS, and ok on iOS.

0

This link might help you

I strongly recommend you to use Google Chrome. I have tried to retrieve passwords from chrome and firefox. Firefox doesn't save passwords securely and anyone with slight knowledge can get them master passwords won't help. But with Chrome it is way harder so, Chrome is a more secure browser.

  • Thank you for the advice, but with hindsight I'm not going to move to Chrome because if done it'll be very difficult to change to another browser : Chrome won't easly let me export my personal data like Firefox do ! – Sam Mar 30 '18 at 18:52
  • that is the point – bogd740 Apr 4 '18 at 0:23
0

This worked for me. After weeks of agonizing over whether to reset my Chrome settings, I finally bit the bullet. Within 1 minute it was all fixed, my passwords were loading within a fraction of a second.

To reset your Chrome settings, click on the three dots (ellipsis) in the top right of the browser and select "Settings". At the bottom of the page select "Advanced" then at the bottom of the (expanded) page under " Reset and clean up", select "Restore settings to their original defaults". Click the blue "Reset settings" button. All fixed in under a minute.

New contributor
Andy Galloway is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.