0

I have an MSI Ghost Pro (GS60).

I can't get it to boot from my SSD. "Hard Disk" and "USB Hard Disk" and others show in the boot options. With my BIOS, it shows more information about the disk and a partition number in the options menu. I also have an option below for "UEFI USB Hard Disk Drive BBS Priorities". I know that I used to have these options for "Hard Disk" too. See below for the back story and BIOS config.

I bought it a few months ago and I installed Fedora 23 from USB stick and erased my Windows installation. I still have the recovery ISOs somewhere.

I remember that after installing from the USB stick it failed to boot from the SSD. After some puzzling and hours of googling I found some instructions to do in the BIOS related to secure boot. Something like do 4 things in the right order and the option magically appears. Unfortunately I don't seem to have this in my bookmarks (doh).

Everything has been going fine until I decided to try Ubuntu 16 live from USB. I changed BIOS to legacy mode. It seems that I hadn't written my Ubuntu USB properly or something. When I changed back, I no longer get the option to boot from SSD. This appears to be exactly what I had before.

Config:

Fast boot: Disabled (quite sure it was Enabled)
SpeedStep: Disabled
ERP lot 3 support: Disabled
Wake on lan: Disabled
Hyper-threading: Enabled
CPU C States: Disabled (certain this was disabled but I used kernel flag to limit to state 7)
Intel Virtualization Technology: Disabled (was enabled)
VT-d: Disabled (was enabled)
SATA Mode Selection: AHCI (was AHCI)

Secure boot: Enabled
Secure Boot Mode: Standard

Other options:

Key management:
  Provision Factory Default Keys: Enabled
  Enroll all Factory Default Keys (this is a command)

I suspect that secure boot was enabled but I'm not certain. Disabling it alone does not help me.

0

I finally got my system booting. I discovered after some more debugging and a bit of luck that although the system was hiding the drive it would enable it.

How did I do this? Magic.

The laptop was without mains power (still with its battery) and turned off for an hour. Later, it just started showing me the NVMe SSD on the Ubuntu I'd installed on my HDD earlier to help debug the boot process.

I'm answering this as my high level problem, my system won't detect my SSD, has been solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.