4

I have an Arch Linux desktop machine with 2 monitors and 4 workspaces.

On the last workspace I usually have Firefox loaded on the left monitor to access Zimbra mail. While on the right monitor I have a VirtualBox running Windows.

Whenever I open a PDF from Zimbra, it always opens on the right monitor in evince and disappears behind the VirtualBox window. I have to right-click the task bar button and chose 'Move' to move the window to the left monitor.

I cannot find any settings that I can change so that the default position of evince is on the left monitor. Can anyone point me to somewhere that I can set this default position?

The left monitor is the 'main' one with the main menu bar at the top and the task bar at the bottom.

It's getting so annoying that I'm seriously looking for an alternative PDF viewer. If anyone knows of a better one, then I'd be happy to move to it.

0

OK, after a bit more Googling I've found a solution to my specific use case.

If I enable PDF previews in Firefox, I can now see the PDF as another tab within Firefox. A lot better.

However, this doesn't really answer the main question about how to make evince open in a specific default position on the screen, so I'm not going to mark my answer as the main answer.

0

See my comment under this answer, rewritten here as a list:

  1. Change Gnome "Tweaks/workspaces" to "workspaces span displays"
  2. Open the file in evince.
  3. Move the application window to that additional monitor and close it there.
  4. Reopen any other file with evince. It should open on the secondary monitor now.

This also works when PDF files are opened from the command line, you might need to restart the shell for the settings to take effect.

1
  • Well it doesn't seem to work reliably. It seems to work if at least one evince window is opened in that other monitor. Maybe make sure that the minimized version (i.e. not the full screen one) of the evince window is entirely on the second monitor before you close it. May 18 '20 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.