1

I want to either: a) make a shortcut to a specific folder on a media device (MTP), or b) create a .bat file or other easy script to open explorer and automatically navigate to the folder where the images are in one click.

The target is "Computer\FinePix AX300\External Memory\DCIM\105_FUJI"

Things I've tried:

I have a shortcut to the device, but several annoying clicks are still required to navigate to the right subfolder. I cannot modify the shortcut because "target location" is greyed out.

I have a .bat file which uses explorer /root, to open in "computer" immediately. However I can't get it to select an object. Meaning this does not work: explorer /root,select,"Computer\FinePix AX300\External Memory\DCIM\105_FUJI" I've done variations of this too.

I cannot change the USB interaction protocol to mass storage either.

Why:

I have to transfer files between a Fuji FinePix AX300 and my PC a lot. I do this via USB not via card reader (because I do it frequently and that takes less fiddling). I need to then modify them, save them, and transfer them to OneNote. This is a poor man's way of joining a paper lab-notebook with a computer one. I have a surface pro but the screen is too small for the scrawling equations and complex diagrams I need (and camera too poor). My "lab-notebook" is actually a huge 18x24 pad of newsprint. In the distant future I will buy the biggest touchscreen I can and get an lynktec active stylus but a shortcut on my desktop is ton cheaper.

Acceptable Alternatives:

If it's easy to install firmware on the FinePix which lets me take photos and stream them straight to the computer that would be nice too. I'm looking for free solutions.

Thanks!

0

I'm assuming your image folder is in X:\DCIM\105_FUJI(replace the X with your drive number)

Create a shortcut

Browse to any folder convenient for you, then right click. Choose New > Shortcut. Click Browse, go to the X:\DCIM\105_FUJI folder, and click OK. Click Next, type in the name you want to appear for the shortcut, and click Finish.

Create a batch file

Create a file wherever it is most convenient for you to use named <Any name>.bat. Right click it and click Edit. Type the following(replacing X w/ your drive #):

start explorer X:\DCIM\105_FUJI

That's it. To run it, you can double click it like you can the shortcut file.


As far as your idea with the giant touchscreen/stylus, I'd say that would be the best way to go in the future.


UPDATE:

Did you try running explorer "Computer\FinePix AX300\External Memory\DCIM\105_FUJI" exactly in the command line(cmd.exe)?

Usually, all devices with an operable file system are assigned a drive letter. IDK why your camera doesn't have one.

You could try the following in your batch file:

@echo off xcopy "Computer\FinePix AX300\External Memory\DCIM\105_FUJI\*" "\folder\with\ONLY\images" for %%x in (*) do "some\path\to\img\editing\program" %%x del /F "Computer\FinePix AX300\External Memory\DCIM\105_FUJI\*"

Some things you should note:

  • The script automatically deletes everything in the camera folder
  • It will create whatever folder you point it to if it doesn't exist
  • Whenever you take a picture, it will be using the same names for the images, unless it classifies the images by date
  • You should be able to assign a drive number to your camera by opening cmd.exe and running subst X: "Computer\FinePix AX300\External Memory\DCIM\105_FUJI\", creating a new X: drive. You could delete it by running subst X: /D

Update #2

This article on How-To Geek really explains your problem well. You can't use just any old file system tool, because MTP(just an extension of PTP) is not a file system. Rather, the computer requests files from the device, which can choose on its' own if it wants to do so or not. ANY action that is performed must be approved by the device, with the computer simply requesting that whatever task be done. Modern operating systems(except Mac) integrate MTP into the file browser, which is how come you can manipulate them in explorer, but not with anything else. The * not found was simply because the camera is not a file system(I guess that's why it doesn't have a drive letter.)

Therefore, you would have to write your own custom tool to interface with the camera. Doing some googling, see if you could access it with an mtp:// prefix.

6
  • The assumption is wrong. The device uses MTP and therefore is not given a drive letter designation. The path "Computer\FinePix AX300\External Memory\DCIM\105_FUJI" is the actual path. I can open explorer and the copy and paste that into the address bar and it works so I figure there is likely a command line equivalent to that which I can put in a .bat file. I wish I could change the devices USB protocol but as far as I know I cannot. – Jojk Jun 9 '16 at 14:31
  • No dice. I tried the commands (in a .bat file or just xcopy in the command line) and it doesn't work. xcopy "Computer\FinePix AX300\External Memory\DCIM\105_FUJI*" "\folder\on\my\pc" returns file not found -*. Removing the wildcard and just trying to copy the whole folder returns invalid path. Here is an example showing the issue with MTP protocol on Android devices. Not all devices get drive letters anymore. (The camera is not Android but is MTP). android.stackexchange.com/questions/22979/… – Jojk Jun 9 '16 at 20:16
  • The explorer command was one of the first things I tried, unfortunately. – Jojk Jun 9 '16 at 20:19
  • Based off this, MTP is NOT a file system. Therefore, it would be impossible to perform generic read/write operations. On my computer, when a camera is plugged in, Autoplay will show up with an option to import pictures/videos. Does your computer show that? – Anonymous Jun 9 '16 at 23:35
  • Autoplay is generally more of a nuisance than a benefit. Autoplay does work it just involves a lot of clicks and that's what I'm trying to avoid. I knew from the beginning that MTP is not a proper file system and that read/write operations from the command line are difficult. That's why I just wanted a shortcut, or a way to make a little program that automates the tasks in explorer. No xcopy or anything like that, just open and display the proper subfolder on an MTP device. – Jojk Jun 11 '16 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.