0

My motherboard is a Gigabyte GA-H170-D3HP, which uses the Realtek HD Audio Manager. I'm on Windows 10 Education x64. I have both speakers and headphones plugged into my computer, and I only use one device at a time. I use nircmd to change the default device between the two and it works very well. The problem, however, is that the audio always plays out of the headphones regardless of which device is the default. If the headphones are the default then sound comes out only the headphones, but if speakers are the default then sound comes out both the speakers and the headphones.

How can I fix this so the audio comes out only the device I have set as the default? I would be fine with outright disabling the non-default device, but I can't find a way to do that via command line. The speakers are plugged into the motherboard, and the headphones are plugged into the front panel.

These are the two config screens in the Realtek utility. I can provide any additional information as needed.

advanced options 1

advanced options 2

  • I suspect this is a hardware limitation. You might be better off with the usual configuration, where plugging in 'phones mutes the speakers, which means that you don't need to do anything with the audio device settings. – AFH Jun 10 '16 at 14:27
  • If you are using ports on front of the case try changing port on motherboard where you plug front mic and heaphones ports. Maybe that changes some options in your Gigabyte software. – user3486470 Jun 25 '16 at 20:56
  • Both the switches in your 'Playback' section appear to be wrong, have you tried enabling the 1st one and disabling the 2nd? – Alok Jun 30 '16 at 1:25
1

Try disabling option 2 ("Make internal and external output devices playback two different audio streams").
Also post a screenshot of your Windows sound configuration.

0

If Windows sees two different drivers for the audio devices, you should be able to get away with disabling the simultaneous playback you have enabled while enabling the conditional mute of the internal device. Your hardware most likely sees the speaker input as any realtek input whereas you have a seperate headphone driver for specifically headphones. Try going into your main speakers menu and muting output on the front port. (I would provide screenshots, but I'm not at my desktop right now.)

0

I had to reinstall Windows for an unrelated reason, and the problem was resolved after that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.