11

The start of each day all my Excel files open very small. After I maximize them, they will open and close just fine for the rest of the day. But the next day they all open small again. Here are some details

  1. I'm not using a shortcut.
  2. I've tried holding the ctrl key when closing the file.
  3. Other Office files work fine.
  4. The behavior shows when in safe mode.
  5. Running Windows 10.

Here is what it looks like...

enter image description here

Whats going on?

5
  • @Dave. Wow, that IS weird. almost exactly the same issue.
    – JimDel
    Jun 9, 2016 at 14:31
  • 1
    can you try closing the file with shift held (instead of CTRL)
    – Dave
    Jun 9, 2016 at 15:17
  • 1
    I have heard that clicking on "New Window" in the "View" tab, and then saving the workbook, will resolve this. See if that works.
    – CharlieRB
    Jun 9, 2016 at 15:25
  • @CharlieRB Well I'm not sure why, but that seems to have worked! Time will tell but so far so good. Thanks!
    – JimDel
    Jun 9, 2016 at 16:58
  • Great. I will post it as an answer.
    – CharlieRB
    Jun 9, 2016 at 17:24

7 Answers 7

9

I have not had to use this, but have heard this will resolve what you are experiencing.

  1. Open Excel
  2. Go to the View tab and click on New Window
  3. Save the workbook

Not sure why it works, other than it most likely resets the window view settings.

8

I had to erase the following registry keys to get it to reset..

Replace 16.0 with whatever version of Office you are running e.g. 14.0, 15.0, etc.

HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Excel\Options  Pos
HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Excel\Options  Maximized

Deleting these two keys with Excel closed will force Excel to recreate the keys, which will resolve the issue.

3
  • Welcome to Super User. Your answer could benefit from more detail. Please edit it to explain how your solution works/how it addresses the OPs question. May 12, 2017 at 13:32
  • This worked for me! Feb 12, 2020 at 8:29
  • This was exactly what I was looking for. Not saying that accepted answers do not work(I've got to admit that I didn't even tried that though), I'm not allowed to save workbook for some reason(Yes, my governor is so weird that he doesn't allow me to save the workbook but allows to delete some registry keys). Saved my day, +1
    – Skye-AT
    Apr 6 at 4:27
2

Excel is trying to "help" you by remembering what you did last.

Here are a few things you could try:

  1. Open Excel, without opening any .xls file (start it by Window+S and type 'Excel'), maximize it, and close.
  2. If the above didn't work, resize the window by dragging the side or corner handles (don't click the maximize button) and close.
  3. Run virus scanner?
1
  • 1
    And this really helped! I have tried all the other advices and only yours worked, thanks! Aug 10, 2019 at 18:24
2

I had the same problem. Worksheet was created in Excel 2013, opened in non-re-sizable window in intranet Excel 2007.

I went to View. New Window was not an option, but "Page Layout" view was. After I opened it in Page Layout view, it expanded to the full page. After I saved the sheet, it behaved normally when reopened.

2

If you have a hidden file that opens on Excel startup, that is minimized, then it can cause Excel to start in that size/shape.

Open Excel, go to the view tab, select 'unhide', and 'unhide' any files. If they are minimized then expand them. If you use macros there is most likely a Personal.XLSB file that is hidden and opens at startup of Excel. Since any file in the startup folder opens first it sets the size.

0

I believe that this problem is related to Snap Assist. If the (Excel) window is resized so that it snaps to the desktop edges the new size isn't saved for future use. Try turning Snap Assist off (Settings -> System -> Multi-tasking).

0
  1. Open Excel from Search button
  2. "Open File Location"
  3. Right Click on the Excel and select Properties
  4. On "Run" field select "Maximized"
  5. Apply + Ok

Not the answer you're looking for? Browse other questions tagged or ask your own question.