1

I'm using prezto with zsh and its "completion" module has some autocorrect stuff which I don't want. I just want the autocomplete and menu highlights, but no autocorrection (which is dangerous and should be forbidden by law! :P )

For example, I have the following directories: src/project/ opensrc/library/

When I type "src/li", it changes to "opensrc/li". I don't want that, or at least no automatically (a y/n prompt would be nice).

Is there any way to disable it without disabling the completion module completely, or have it prompt (y/n)?

2

I seem to have found the solution. Add the following lines to the .zshrc file, and it should stop the autocorrection:

unsetopt correct
unsetopt correctall
DISABLE_CORRECTION="true"
0

Tracking the 'completion' module in github you will find this notice:

This projects aims at gathering/developing new completion scripts that are not available in Zsh yet. The scripts are meant to be contributed to the Zsh project when stable enough.

This module is not stable enough. Just disable it in ~/.zpreztorc.

You will still get basic, Bash-style tab completion in zsh.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.