0

I'm trying to install some USB 3.0 drivers which I think are right for my motherboard (the computer is a Compaq laptop with "15-s108na" on the label on the back and I got the driver at https://driverscollection.com/Search/ by looking up compaq 15-s108na usb 3.0 and picked the first thing, so I think I have the right thing) into the boot.wim and install.wim files of a bootable Windows 7 Ultimate Edition USB key so I can install, because I keep getting errors about CD/DVD drivers being missing.

Now I'm trying to install it by following this guide: http://codeabitwiser.com/2014/03/how-to-install-windows-7-with-only-usb-3-0-ports/ but I'm having so many problems...

What I did by steps in the link

Step 1:

Downloaded the driver .exe shown above and all the drivers shown in the list in the link for good measure (I don't think putting them in the boot.wim will cause any problems if they aren't useful?) except the last one (VIA VL800/801 & 805/806 USB 3.0) because the link just redirects to the home page and I can't find it.

Step 2:

Made a new folder in Documents called >b>mylifeishell.

Made USB3 and mount folders inside that.

Put all the drivers including Compaq .exe in USB3. (I extracted the folder in Intel(R)_USB_3.0_eXtensible_Host_Controller_Driver.zip and put that in but I didn't know what to do with USB3.0_allOS_2.1.28.1_PV so I left that the way it was).

Step 3

Fished the boot.wim and install.wim files out of my bootable Windows 7 Ultimate USB stick and put them into mylifeishell folder, as instructed.

Step 4

Opened cmd.exe as administrator.

Typed dism /mount-wim /wimfile:boot.wim /index:2 /mountdir:mount Result was:

Error: 2

The system cannot find the file specified.

So insteaad, I got more specific with the location of boot.wim and mount: dism /mount-wim /wimfile:"C:\Users\name\Documents\mylifeishell\boot.wim" /index:2 /mountdir:"C:\Users\name\Documents\mylifeishell\mount"

This works, a percent bar appears and charges up to 100.0% and says The operation completed successfully.

I then proceed to type the second line, dism /image:mount /add-driver:"usb3" /recurse, provoking this error;

Error: 2

Unable to access the image.

Make sure that the image path and the windows directory for the image exist and you have Read permisions on the folder.

I then modified the command with exact path of the USB3 folder again; dism /image:mount /add-driver:"C:\Users\name\Documents\mylifeishell\USB3" /recurse

This gives exactly the same error, 2, as last time, so I alter the image:mount part too in case it needs to be reminded what directory it's mounting. dism /image:"C:\Users\name\Documents\mylifeishell\mount" /add-driver:"C:\Users\name\Documents\mylifeishell\USB3" /recurse

Resulting in;

Error: 3

Unable to access the image.

Make sure that the image path and the Windows directory for the image exist and ou hve Read permissions on the folder.

Then I tried to specify a specific file in the USB3 folder, without specifying the file path of the mount folder: dism /image:mount /add-driver:"C:\Users\name\Documents\mylifeishell\USB3\USB3.0_allOS_2.1.28.1_PV.exe" /recurse and got Error 2 again. With mount file path:dism /image:"C:\Users\name\Documents\mylifeishell\mount" /add-driver:"C:\Users\name\Documents\mylifeishell\USB3\USB3.0_allOS_2.1.28.1_PV.exe" /recurse . Got Error 3 again.

I have no idea what to do and am slowly running out of time here. Maybe if someone could make me the .wim files and leave them in a download link. I would happily kiss your dog on the lips and send you Christmas cards forever.

  • Why not get the drivers directly from HP / Compaq? --> support.hp.com/us-en/drivers/selfservice/… also if I'm reading this correctly .. is there a reason why you want to create a windows installer with the driver built in? Can't you just simply start windows installation and then install the usb driver afterwards? – Darius Jun 10 '16 at 2:24
  • I can't find anything on that page, the windows installer is sticking and prompting me for drivers so I can't install until I have them apparenrly – James Jun 10 '16 at 13:57
  • If the windows installer is prompting you for driver, you usually have the chance of putting a USB (or a CD/DVD) that has the driver package (preferably extracted out of the single .exe file - so you can see all the .inf files). – Darius Jun 10 '16 at 22:21
3

You can't point to an Exe in DISM:

/add-driver:"C:\Users\name\Documents\mylifeishell\USB3\USB3.0_allOS_2.1.28.1_PV.exe"

Extarct the Exe and point to the extracted driver :

/add-driver:<fullpath>\FUSB3_allOS_2.1.28.1_PV\Files\x86

Also make sure you run the cmd as admin.

Your other mistake is your incomplete mount path.

Use this folder structure:

Create a folder 7Work and 3 folders DVD, drivers and Mount. Copy the Windows 7 DVD/ISO content to DVD and run this command to mount the WIM:

dism /mount-wim /wimfile:D:\7work\DVD\sources\boot.wim /index:2 /mountdir:D:\7work\mount

Now copy the USB drivers into 7work\drivers\USB3:

enter image description here

Now run the DISM command to add drivers:

dism /image:D:\7work\mount /add-driver:D:\7Work\Drivers\USB3 /recurse

enter image description here

This works fine. Now unmount commit the changes.

Dism /Unmount-Image /MountDir:D:\7work\mount /commit

enter image description here

Now replace the original boot.wim on the usb flash drive with the modified boot.wim from D:\7Work\DVD\sources.

  • It's still sneezing up error 2 even though I'm running cmd as admin. – James Jun 10 '16 at 13:55
  • error 2 = file not found. Check that the paths are fine. This example is for 86 (32Bit). If you have 64 Bit Windows use the x64 folder – magicandre1981 Jun 10 '16 at 14:54
  • I am sure the paths are fine which is what's driving me crazy. I've checked them nearly ten times... – James Jun 10 '16 at 16:12
  • 1
    "Unable to access the image unable to access the unable to access the image unable to access the image" ffff – James Jun 10 '16 at 17:17
  • 1
    your mount path is incomplete. Use a proper folder. I use D:\7work as base. Add here a folder DVD and copy all Win7 data in it. Now create a folder Mount in it and dism /mount-wim /wimfile:D:\7work\DVD\sources\boot.wim /index:2 /mountdir:D:\7work\mount – magicandre1981 Jun 11 '16 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.