4

So I'm trying to fix this problem for a while now and have seen many similar problems, but all of them got solved through one of the steps listed below - not mine. The problem is:

Ethernet cable connected from home router to the port results in no network connection. It shows:

  • first 15-20 seconds all the icons are fine, the network center shows "connected". Can't ping any website despite that though.
  • right after I get the exclamation mark with yellow triangle icon as the connection icon. And it stays like that.

My gear is Samsung RF-511 S04 with Windows 7 x64 Home Premium SP1.

What I've checked:

  • first I disconnected wireless card, Ethernet is still on of course.
  • different cable doesn't work
  • different router port doesn't work
  • other ubuntu laptop works
  • finally - switching to ubuntu on my "broken" laptop works

So I know the network card is fine. What I did next:

  • I see the default gate for ethernet is fine.
  • I updated (didn't help), uninstalled and installed back again the drivers, didn't help either.
  • The Windows diagnostic tool reports no problems found.

Any clue what could I check next? I would appreciate any hint on that.

edit
@user604857 Kevin The ipconfig /all for the ethernet connection below:

Ethernet adapter local area connection:

Connection-specific DNS Suffix : home
Description. . . . . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . . : E8-11-32-99-FA-BB
DHCP Enabled . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address . . . . . . . . . . . . . : 192.168.1.11(Preferred)
Subnet Mask. . . . . . . . . . : 255.255.255.0
Lease obtained. . . . . . . . : 11 June 2016 19:52:03
Lease Expires. . . . . . . . . : 12 June 2016 19:52:03
Default gateway. . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
192.168.1.1
NetBIOS over Tcpip . . . . . . . : Enabled

Looks like I have IPv6 physical address, though I have IPv6 disabled in the properties and IPv4 set to automatic - see screenshot - not in English, sorry, but it should be recognisable.

screenshot

  • how on earth have you not attempted reinstalling drivers for your network card – barlop Jun 12 '16 at 19:26
  • "I updated (didn't help), uninstalled and installed back again the drivers, didn't help either." <- I guess that's what you mean I had to do? – adamczi Jun 12 '16 at 19:35
  • ok this probably won't help but what about right click hten click diagnose ptd.net/sites/default/files/… (win7 has that option and you're on win7) – barlop Jun 12 '16 at 19:37
  • just foudn these two programs, can't vouch for tem but may help. they're reputable sites. majorgeeks i'd be surprised if any of their stuff had malware and bleepingcomputer is an anti malware site so definitely no malware there majorgeeks.com/files/details/complete_internet_repair.html and bleepingcomputer.com/download/netadapter-repair-all-in-one and a thing you can download here support.microsoft.com/en-gb/kb/936211 a microsoft fix it thing. All long shots. – barlop Jun 12 '16 at 19:41
  • 1
    A fresh windows doesn't necessarily mean wiping it, you could make a new partition and put windows on it or try it on another hard drive lying around. Anyhow, if it works under WinPE(not such hassle as run off a CD/USB) it increases the chances greatly, that it will work under a fresh windows, and if it works under a fresh windows, then you know that recreating your windows installation would be an option for a fix that would work. And if for some bizarre reason a fresh win installation doesn't work then you know that wiping ur existing windows installation to try to make it work is futile – barlop Jun 15 '16 at 11:52
1

Any clue what could I check next?

Reinitialise the network states by running the following commands in a cmd shell:

  1. Reset WINSOCK entries to installation defaults:

    netsh winsock reset catalog
    
  2. Reset TCP/IP stack to installation defaults:

    netsh int ip reset reset.log
    
  3. Reset Firewall to installation defaults:

    netsh advfirewall reset
    
  4. Flush DNS resolver cache :

    ipconfig /flushdns
    
  5. Renew DNS client registration and refresh DHCP leases:

    ipconfig /registerdns
    
  6. Flush routing table:

    route /f
    

    This last command requires a restart.

Note:

  • See the last two further reading links for further things to try.

Further Reading

  • Thank you. I did above, with rebooting, but it didn't change the situation. – adamczi Jun 10 '16 at 18:02
  • 1
    For the record hanselman.com/blog/… and a related superuser link with a bunch of these commands superuser.com/questions/163150/… – barlop Jun 12 '16 at 19:30
  • @barlop Thanks for the comment. I will add to the answer for completeness. – DavidPostill Jun 12 '16 at 20:08
  • Resetting the crap out of my network adapter didn't help, I'll research other links you posted, thanks. – adamczi Jun 15 '16 at 12:01
0

I think its worth eliminating the DHCP element so set a new manual ip address with same gateway and try again. Also when you try with Ubuntu record the ip address used and other details.

By the way, the Physical Address displayed is nothing to do with IPV6. It is the Hardware or Mac Address of your Ethernet port. Every network device has a Mac address encoded when the device is made in the factory

In addition you should connect to the management page of the router and check its network setup ip nets or sub nets and verify the settings relating to the ethernet port. Presumably you should be able to do this with ubuntu. Then set up logging on the device, retry your ethernet connection, back to ubuntu to check the log!

If you still dont want to go down the wipe route, we need to test the known facts more rigorously. can you supply the ip addresses masks and gateways on each device in your testing especially when you tried static addresses and confirm that you are not using a crossover cable inadvertently (the same cable should be used in all tests). In fact the simplest test would be with a crossover cable or alternatively a switch with only your good ubuntu laptop and the bad one connected then set up both ethernet ports:-

with:

good ubuntu:- static address 10.0.0.1 mask 255.255.255.0 gateway 10.0.0.2

windows:- static address 10.0.0.2 mask 255.255.255.0 gateway 10.0.0.1

and try to ping if it works the port hardware should be ok.

  • With other pc I checked how the router behaves when I connect to it - everything seems to be correct, compared to another ethernet connection, at least there are no limitations. Can't get the system logs of the router because it's provided by an ISP (not a super-configurable gear). Though I tried assigning static IP address - no result. – adamczi Jun 15 '16 at 9:53
-1

I seem to remember that Windows does not usually handle both wifi and ethernet port being enabled at the same time - unless the machine is a server. So I would go into the network tool and disable wifi and then enable the ethernet driver, and test the ethernet port. In the microsoft world only servers are allowed to be 'multi homed' - that is, operate 2 network ports simultaneously. It ensures that people have to buy the Server Operating Systems! hope this helps

  • It appears that my non-Server Windows 8 machine is able to use both Ethernet and Wi-Fi at once. – Ben N Jun 12 '16 at 2:41
  • Hi, thanks. I wrote in the description that I turned off the wireless card as a first step. – adamczi Jun 12 '16 at 7:03
  • And Ben N seems to be right, I remember I didn't have any issue with the ethernet-wifi mix in Win XP x32 and Win7 x64. Just plugged in a cable and disabled wi-fi (what even wasn't always neccessary - it turned off by itself) – adamczi Jun 12 '16 at 11:47
  • -1 if what you were saying were true then a)have a proper source (it'd be a well known problem if it were true) and b)He is not describing some issue of ethernet card xor wireless. He's saying his ethernet socket is not working on windows at all, whether wireless is on or off. So what you're saying which is probably false anyway, is irrelevant. – barlop Jun 12 '16 at 19:27
  • @BenN yeah this answer can't be right and is completely unsourced and isn't even addressing the problem the OP is having – barlop Jun 12 '16 at 19:28

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.