I had dual boot Windows 10 and Ubuntu 14.04..Anyway I formatted the partition that Windows 10 Installed On and Ubuntu too..After that I installed Kali Linux as Primay OS Without any dual boot or OS Inside it..So i noticed that it can't mount the partitions unless if i run this command in the terminal:

mount -t ntfs-3g -o ro /dev/sda6 /media/drive

Like this..But if i run this command:

mount -o -ro /dev/sda6 /media/drive

It will not mount..But Anyway in the first condition it need to run this command again after restart the Laptop..But in the second condition It returns this error:

The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount. Failed to mount '/dev/sda6': Operation not permitted The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option.

So How this Can be Fixed?

1 Answer 1


Solved, Use GParted then select the partition that you can't mount then right click and choose "Check" and It will find the problem and solve it automatically.

You must log in to answer this question.