My machine is an eMachines w3107 (2005 CSM/Legacy BIOS Machine) and I seem to have an issue with booting from USB flash drives, even with the proper partition table. I have had this issue many times on other computers and it ended up being because of an invalid partition table.

This problem is different. The USB flash drive isn't showing up as a bootable removable device in my boot device options. I have tried everything I could find online to overcome this issue.

When I force the computer to boot from removable media, the computer hangs with a blinking underscore. As far as I can tell, I can only do Ctrl+Alt+Delete to reboot.

Any help on this problem? Without a UEFI enabled BIOS, no help is currently available elsewhere.

  • My answer here might help someone with this problem. Has to do with older BIOS vs UEFI. Jul 12, 2018 at 17:44
  • Most people installing linux already knows that the linux live cd boot loader does not support GPT partition scheme
    – user549452
    Jul 14, 2018 at 0:33

3 Answers 3


Plop Linux to the rescue!

That'll add a lot of life to legacy machines whose BIOS can't handle booting from a USB. It's easiest if you can burn it to a CD or DVD and boot Plop from that. That will allow you to redirect to your USB device. If you don't have a CD, there are other ways, including using a floppy or, if you have an OS installed on a bootable drive, adding an entry for Plop to your boot manager. You can also just install another hard drive (or use a new partition on an existing drive) and install Plop to there. Any of those will allow you to boot Plop and then redirect to the USB device.

Check out youtube for videos like this one.

  • If you have a hard drive that you can write to, then you can install it in the machine and install plop on there. Then boot from that drive. That would then allow you to redirect to boot off of the USB.
    – Diagon
    Jun 11, 2016 at 4:33
  • I have no computer in the house that supports IDE except for that one, and I may be able to write to the drive using a recovery CD. The issue is I removed the boot partition in hopes of software to remaster it with the latest features. The boot partition before had Windows XP on it because of how Windows XP handled partitions.
    – user549452
    Jun 11, 2016 at 16:55
  • Well, do you have a USB enclosure for that IDE drive? You could use another computer to install Plop to that drive via USB. Then, you could remove the drive and install it in the target computer using the IDE interface. Since it's linux, it'll boot.
    – Diagon
    Jun 11, 2016 at 21:46
  • Turns out that Plop Boot Manager didn't work for anything, I got it working on a CD-RW. But nothing I want to boot off a USB is supported by Plop (it freezes), such as Lubuntu, Ubuntu, Windows (CSM), Windows (UEFI), ect. Pretty much everything you could think of doesn't work for me.
    – user549452
    Jun 12, 2016 at 16:11
  • Well that's definitely weird. It's never failed for me - and I do use old equipment. How did you make those USB's? What happens when you burn a CD with ubuntu or the like and just boot from that?
    – Diagon
    Jun 13, 2016 at 19:37

Turns out certain file-system setups make this desktop detect the flash drive as a hard drive.
So pretty much it wasn't detected as a removable device, and instead a hard drive by the BIOS. Perfectly able to boot into installation media now by taking the different boot device path no problem.

Screenshot NO.1 Screenshot NO.2

  • So the problem wasn't that you tried to boot from it and failed, it was that you wanted to set the boot order or select it as the boot device and it was hiding as a hard drive rather than being listed as a removable device? Sneaky little devil!
    – fixer1234
    Jan 9, 2017 at 21:59
  • @fixer1234 Yeah I tried to edit my original question accordingly, I just don't want to change too much about the question either.
    – user549452
    Jan 9, 2017 at 23:08

I also had a blinking cursor, when I followed the instruction from https://askubuntu.com/questions/372607/how-to-create-a-bootable-ubuntu-usb-flash-drive-from-terminal. Then I used /dev/sdc and not /dev/sdc <?> to created the bootable usb, as suggested in an edit note, and then it worked.

You must log in to answer this question.