1

I am trying to install eclipse and Java on my computer. I installed both JDK 7u80 and JRE7u80 fine, and have downloaded eclipse, but when I run the eclipse application, it shows this error: A JRE or JDK must be available in order to run Eclipse. No Java virtual machine was found after searching the following locations: bla bla bla. I tried moving the eclipse folder to where I installed java, but the same error showed up. How do I fix this?

P.S. If someone can tell me how to download java 8u45 without having to create an account, that would be much appreciated as well.

  • If you download the eclipse installer, it should set it all up for you. eclipse.org/downloads. It is at the top with "try eclipse installer". – f3rn0s Jun 11 '16 at 15:24
  • I am so dumb. I had no Idea that this was here. I will tell you if it works. – John Hickox Jun 11 '16 at 15:29
  • @Tealkine, when I try to run the installer, it opens up a web site saying there is no JRE/JDK installed. I tried uninstalling my java, and Installing the latest version of java 8, but the same thing happened. What do I do? – John Hickox Jun 11 '16 at 15:34
  • I am dumb. I used the x86 version of java instead of x64. It now works – John Hickox Jun 11 '16 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.